


 Before You Read This Guide
Thank you for purchasing CLIP STUDIO PAINT. This section describes points to be aware of when reading this guide.

Notations in This Guide
This guide (including its data form) was written and edited based on the most recent version of this software product as of April 2018, and may 
differ from the specifications of your actual software product.

About Operations Described in This Guide
Operations in this guide are described based on the Windows version unless otherwise noted.

If you are a mac OS user or iPad user, replace and read as indicated below. When replaced, operation on both Windows, mac OS, and iPad have 
the same meaning.

Signs
This guide uses signs to indicate explanations related to operations. The signs have the following meanings.

 To use shortcut keys on an iPad, please connect keyboard to it.

 It is possible to use the edge keyboard on the iPad. The edge keyboard is a tool to assist with the input of 
modifier keys and such. For details on operating the edge keyboard, please refer to  "Edge Keyboard (iPad)" .

Windows macOS iPad

[Alt] key [Option] key [Option] key

[Ctrl] key [Command] key [Command] key

[Enter] key [Return] key [Return] key

[Backspace] key [Delete] key [Delete] key

Right click (mouse button)
Mouse click with the [Control] key 
down

 Tap while pressing the [Con-
trol] key 

 Long press with finger.

Indicates items that may be easily mistaken or matters to be aware of when using CLIP STUDIO PAINT.

Indicates tips and supplementary information useful when using CLIP STUDIO PAINT.
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Product Grades
CLIP STUDIO PAINT comes in three product grades: DEBUT, PRO and EX. This guide describes operations in all three grades. Functions 
that are only available in certain grades are marked with those product grades.

Trademarks and Copyrights
 CELSYS, CLIP STUDIO, CLIP, QUMARION, IllustStudio and ComicStudio are trademarks or registered trademarks of CELSYS, Inc.

 Windows is a registered trademark of Microsoft Corporation in the United States and other countries.

 Mac, macOS, iPad are trademarks or registered trademarks of Apple Inc. in the United States and other countries.

 iOS is a trademark or registered trademark of Cisco System Inc. in the United States and other countries and is used under license. 

 Adobe, the Adobe logo and Adobe Reader are trademarks of Adobe Systems Incorporated in the United States and other countries.

 All other company names and product names described herein are trademarks or registered trademarks of their respective holders.

 No part of this guide (including data) may be reproduced or copied in any form or by any means without permission from the copyright 
holder, except when so required by law.

Unmarked Indicates a function common to CLIP STUDIO PAINT DEBUT, PRO and EX.

[DEBUT] Indicates a function available only in CLIP STUDIO PAINT DEBUT.

[PRO] Indicates a function available only in CLIP STUDIO PAINT PRO.

[EX] Indicates a function available only in CLIP STUDIO PAINT EX.
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Before Drawing a Work in 
CLIP STUDIO PAINT
This section describes works drawn in CLIP STUDIO PAINT and how to perform basic operations in CLIP 
STUDIO PAINT.



Before Drawing a Work in CLIP STUDIO PAINT > Operations Available in CLIP STUDIO PAINT
Before Drawing a Work in CLIP STUDIO PAINT

 Operations Available in CLIP STUDIO PAINT
CLIP STUDIO PAINT is software that has everything you need to create manga and illustrations, including a pen tool
with a natural, realistic touch, a brush tool allowing a variety of painting styles, and an easy-to-use coloring tool for
efficient, beautiful coloring.

This section provides a brief description of the functions that are available in CLIP STUDIO PAINT, with actual works as
examples.

A Natural, Realistic Touch With A Variety of Styles
This software has a sophisticated pen pressure detection function for a natural, realistic touch.

A wide range of settings can be customized, including a "correction function" for reducing blurring and disarray of lines, "starting" and "end-
ing" settings to create lines resembling real pen strokes by gradually changing the line width at the start and end of the lines, a "brush stroke" 
function to taper the ends of lines and various brush shapes that can be selected according to the line type and situation. The interface is fully 
customizable. 

Variety of Painting Styles
Choose from a variety of different painting functions to suit your style, from watercolors for a delicate touch, oil paint for depth or animation 
painting to recreate the look of cel animation.

The brush tool can be customized in various ways, such as changing the tip shape, adding texture or recreating the strokes produced by water-
color paints. After changing the brush settings, you can save the settings as an original brush.

You can also draw patterns with the [Decoration] tool, including complex patterns such as lace, chains and vegetation. The software also 
includes patterns that can be used for backgrounds or to express a mood.

The pen tool provides a natural, smooth touch Advanced settings can be configured on the [Tool Property]

palette and [Sub Tool Detail] palette [PRO/EX]

Create a watercolor effect The decoration tool has many different types of decoration
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Before Drawing a Work in CLIP STUDIO PAINT > Operations Available in CLIP STUDIO PAINT
Resolution Free for Beautiful Lines and Easy Editing [PRO/EX]
The expanded vector format allows styles such as pencil and brush as well as pen. The same beautiful line quality is achieved no matter how far 
the image is scaled up or down, and you can change the shape or width of lines after drawing. The software also includes convenient functions 
allowing you to erase lines up to the point where they intersect or erase only one of two overlaid lines.

All the Functions You Need for Manga, Including Unlimited Tones [PRO/EX]
CLIP STUDIO PAINT also has all the functions you need to create manga, such as creating borders and frame borders, drawing effect lines, 
applying tones and creating balloons.

As tones are particularly essential in manga, the software has an extensive tone function. Simply turn on "Toning" in [Layer Property] to con-
vert the tone of your drawings to black and white dots. The drawings can be edited freely at any time, including adding or removing areas as 
necessary or changing the screen frequency, density or halftone shape.

The [Frame Border] folder allows you to create frame borders for your manga simply by dragging the mouse across the canvas to draw border 
lines.

Pen Spray Heart Laced ribbon

The line shapes can be changed freely Use the vector to erase the drawn gray lines up to the intersection.

Various tools such as the pen can be used to change the brush shape in the 

drawing

Express in black and white halftone dots by toning You can express your strokes in black-and-white halftone dots.

Use blending modes to add color to the dots.
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Before Drawing a Work in CLIP STUDIO PAINT > Starting
 Starting
This part will explain how to launch CLIP STUDIO PAINT and its initial screen.

When using Windows/macOS

1 Once the installation of CLIP STUDIO PAINT is complete, a corresponding portal applica-
tion "CLIP STUDIO” icon will be automatically created. Click the CLIP STUDIO icon.

2 Click [PAINT] after starting CLIP STUDIO.

3 CLIP STUDIO PAINT starts.
A white canvas is automatically created after CLIP STUDIO PAINT starts. The canvas (the white area displayed in the middle) is equiva-
lent to the paper used when drawing illustrations in non-digital form. Draw your images here.
CLIP STUDIO PAINT STARTUP GUIDE 7



Before Drawing a Work in CLIP STUDIO PAINT > Starting
Screen Configuration
This section describes the elements such as palettes that are displayed by default.

(1) [Tool] palette This allows you to select tools for drawing illustrations or manga.

(2) [Sub tool] palette This allows you to change the settings of each tool.

(3) [Tool Property] palette This allows you to adjust the settings of the currently selected sub tool.

(4) [Brush size] palette This allows you to adjust the size of the brush currently being used.

(5) [Color] palette This allows you to select the drawing color.

(6) [Command] bar
This allows you to quickly perform operations such as creating a new canvas 
or saving your canvas.

(7) [Quick Access] palette
With this palette, you can register your frequently used tools, menu com-
mands, and colors. Registered functions can be used from the [Quick Access] 
palette.

(8) [Material] palette
This palette is used to manage the various materials used for drawing illustra-
tions and manga. The materials can be dragged and dropped to the canvas for 
use.

(9) [Navigator] palette
Manages the view of the image displayed on the canvas window. This allows 
you to adjust settings such as the display position, scale and angle.

(10)[Layer Property] palette [PRO/EX]
This allows you to configure various settings for layers. It can also be used to 
display and switch tools and sub tools available for use in the selected layer.

(11) [Layer] palette
This allows you to manage your layers, which are essential for digital illustra-
tions and manga.
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Before Drawing a Work in CLIP STUDIO PAINT > Starting
When using an iPad

1 Tap the Clip Studio icon.

2 CLIP STUDIO PAINT starts.
A white canvas is automatically created after CLIP STUDIO PAINT starts. The canvas (the white area displayed in the middle) is equiva-
lent to the paper used when drawing illustrations in non-digital form.

(12) [Timeline] palette
It is the palette that can decide the timing and superposition of visible cels 
regarding the animation timeline.

(13) [All sides view] Palette [EX]
A palette for displaying 3D materials on 3D layers from four directions. 
When a 3D material is placed on the layer, it can be viewed from four direc-
tions at the same time. 
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Before Drawing a Work in CLIP STUDIO PAINT > Starting
Screen Configuration
This section describes the elements such as palettes that are displayed by default.

(1) [Tool] palette This allows you to select tools for drawing illustrations or manga.

(2) [Quick Access] palette
Tap to display the [Quick Access] palette. With this palette, you can register 
your frequently used tools, menu commands, and colors. Registered functions 
can be used from the [Quick Access] palette.

(3) [Sub Tool] palette
Tap to display the [Sub Tool] palette. This allows you to change the settings 
of each tool.

(4) [Tool Property] palette
Tap to display the [Tool Property] palette. This allows you to adjust the set-
tings of the currently selected sub tool.

(5) [Brush Size] palette
Tap to display the [Brush Size] palette. This allows you to adjust the size of 
the brush currently being used.

(6) [Color Wheel] palette
Tap to display the [Color Wheel] palette. Tap or drag within the [Color 
Wheel] to select a drawing color.

(7) [Color Set] palette
Tap to display the [Color Set] palette. In addition to selecting a color from a 
list of typical colors, this allows you to register and manage frequently used 
colors as a [Color Set].

(8) [Color History] palette
Tap to display the [Color History] palette. This shows your recently used col-
ors. You can select a drawing color by clicking the tiles.
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Before Drawing a Work in CLIP STUDIO PAINT > Starting
Changing the interface color
In CLIP STUDIO PAINT it is possible to change the interface color.

Select the [File] menu → [CLIP STUDIO PAINT] menu for macOS/iPad) → [Preferences].

You can change the color via the [Color] settings by selecting [Interface] in the [Preferences] dialog.

(9) [Layer Property] palette
Tap to display the [Layer Property] palette. This allows you to configure var-
ious settings for layers. It can also be used to display and switch tools and sub 
tools available for use in the selected layer.

(10) [Layer] palette
Tap to display the [Layer] palette. This allows you to manage your layers, 
which are essential for digital illustrations and manga.

(11) [Material] palette
Tap to display the [Material] palette. This palette is used to manage the vari-
ous materials used for drawing illustrations and manga. The materials can be 
dragged to the canvas for use.

(12) [Command] bar
This allows you to quickly perform operations such as creating a new canvas 
or saving your canvas.
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Before Drawing a Work in CLIP STUDIO PAINT > Preparations
 Preparations
This section describes the basic preparations for drawing illustrations.

Change the Canvas Size and Resolution
A canvas is generated automatically when CLIP STUDIO PAINT is started.

To create a canvas with your preferred settings, change the settings or create a new canvas.

Changing the Settings
From the [Edit] menu, select [Change Image Resolution] or [Change Canvas Size].

Selecting [Change Image Resolution] allows you to change the width and/or height proportionately.

Selecting [Change Canvas Size] allows you to change the width and/or height freely.

Creating a New Canvas
From the [File] menu, select [New]. In the [New] dialog, configure settings such as "Use of work" (PRO/EX), "Width", "Height", "Resolution" 
and "Basic expression color" (PRO/EX) and then click the [OK] button.
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Before Drawing a Work in CLIP STUDIO PAINT > Preparations
Try Drawing with the Drawing Tool
First, try drawing lines on the canvas.

When using a tablet with a pen, you can draw thicker lines by pressing harder or thinner lines by drawing more lightly (the line size depends on 
the pen pressure). There are various drawing tools, such as [Pen], [Pencil] and [Decoration].

After testing the tools, you can batch-erase the entire image by pressing the [Delete] key.

Tips: If you make a mistake while operating
You can undo mistaken operations and restore the image to its previous state. Click the [Undo] button on the [Tool] bar to undo the last opera-
tion.

When using an iPad, you can undo operations by tapping the canvas with two fingers.

 A desired size can be pre-installed using the [Default size] setting. Click the [Preset] pull-down menu to dis-
play the list of canvas settings and select your desired setting.

 You can also click [Register to preset] to the right of [Preset] to add the settings configured in the [New] dialog 
box as a preset item.

 In PRO/EX, selecting an item for [Use of work] displays setting suited to the selected use.

 Preset items are managed for each use of work. The registered [Preset] can be used when selecting the same 
use of work for which the [Preset] item was registered or when [Show all settings] is selected.

[Undo]
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Before Drawing a Work in CLIP STUDIO PAINT > Preparations
Adjust the Pen Pressure
This section explains how to batch-adjust the pen pressure for all tools that use pen pressure. CLIP STUDIO PAINT also allows you to config-
ure different pen pressure settings for each brush.

Select [File] menu ([CLIP STUDIO PAINT] menu for macOS/iPad) → [Pen Pressure Settings] to bring up the [Adjust pen pressure] dialog 
box.

Draw on the canvas with your stylus while intentionally varying your pen pressure. When you’ve finished drawing, click [Check adjusted set-
tings].

When the [Check adjusted settings] dialog box appears, you can try out the adjusted pen pressure sensitivity.

Draw on the canvas with the new settings.

You can adjust the pen pressure sensitivity with the [Stronger] and [Lighter] buttons.

Adjust the settings as much as you like. When you’re finished, click [Done] to exit the dialog box. Clicking [Done] will apply this pen pressure 
setting to all tools.

Vary the thicknesses of the stroke
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Before Drawing a Work in CLIP STUDIO PAINT > Page Management [EX]
 Page Management [EX]
In CLIP STUDIO PAINT EX, you can create a "management file" to manage manga works with multiple pages. In this
section, you can learn how to use management files.

Creating a Management File
From the [File] menu, select [New]. Turn on [Multiple pages] in the [New] dialog box and specify the number of pages. Click the [OK] button 
to create the management file.

Configure the Binding Point and Start Page
The binding point and start page of the work can be set in the [Binding point] and [Start page] items that are displayed when [Multiple pages] is 
turned on in the [New] dialog box.

Managing Multiple Pages
This section explains how to manage multiple pages using a management file.

Page Manager Window
This window is used to manage management files. Select [Story] menu → [Page Manager] to display the [Page Manager] window. Double 
clicking a page thumbnail opens the corresponding page file.

[Multiple pages] cannot be set if [Illustration] is selected as the [Use of work].
CLIP STUDIO PAINT STARTUP GUIDE 15



Before Drawing a Work in CLIP STUDIO PAINT > Page Management [EX]
Adding and Deleting Pages
Click a page thumbnail in the [Page Manager] window to select the page.

Select [Story] menu → [Add Page] to add a new page after the selected page.

Select [Story] menu → [Delete Page] to delete the selected page.

Changing the Page Order
In the [Page Manager] window, select the page to be moved and drag it to the desired position.

Setting a Spread or Single Pages
Select the pages to be combined in the [Page Manager] window. Select [Story] menu → [Combine Pages] to combine the pages as a spread. 
Spread pages can also be split into single pages by selecting [Story] menu → [Split Pages]. Neither operation can be undone using the [Undo] 
function.

Switching the Displayed Page
Click the [Switch canvas] tab to switch the displayed page.

Pages must be added and deleted in the [Page Manager] window.

The page order must be changed in the [Page Manager] window.

Drag to the

desired position

2 pages Combine as one page to create a spread
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Before Drawing a Work in CLIP STUDIO PAINT > Basic Canvas Operations and Shortcuts
 Basic Canvas Operations and Shortcuts
When drawing illustrations and manga, you can zoom in on the canvas to draw fine details or zoom out to check the
overall balance of the canvas. Here you can learn about the basic canvas operations you need to know when drawing
an illustration.

Basic Canvas Operations
To operate the canvas, your can either utilize tools and touch gestures, or use the [Navigator] palette.

Scaling the Canvas Up and Down (Zoom In/Zoom Out)
A slider and buttons for adjusting the scale can be found at the bottom left of the canvas and in the [Navigator] palette.

(1) Slider? Move the slider to the left to scale the canvas down or to the right to scale it up.

(2) [-]? Scales the canvas down.

(3) [+]? Scales the canvas up.

Showing the Whole Canvas
Press [Ctrl] + [0] (zero) together on the keyboard to show the whole canvas.

In the macOS version, press [Command] + [0] (zero) together.

On the iPad, double tap the “Hand” tool icon in the “Tools” palette.

Scrolling Across the Canvas
When using a Windows/macOS, scroll bars can be found at the bottom and on the right side of the canvas. Move the scroll bars to scroll verti-
cally and horizontally through the canvas to change the area that is displayed.

If the [Navigator] palette is not displayed, please select it in the [Window] menu → [Navigator] to display it.

If you are using an iPad, you can display the scroll bar by selecting the [Window] menu → [Scroll Bar].
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Before Drawing a Work in CLIP STUDIO PAINT > Basic Canvas Operations and Shortcuts
You can also move the canvas to change the displayed area by using the [Hand] tool on the [Tool] palette. Select the [Move] tool from the 
[Tool] palette and select the [Hand] sub tool from the [Sub tool] palette.

Click the canvas and drag to move the canvas freely.

You can move the canvas freely by swiping with two fingers on the canvas, when using an iPad. There is no need to select a tool.

Flipping the Canvas Horizontally
You can flip the canvas horizontally to make it easier to draw or to check the balance of the picture while drawing.

Drag
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Before Drawing a Work in CLIP STUDIO PAINT > Basic Canvas Operations and Shortcuts
Click [Flip Horizontal] on the [Navigator] palette.

In the [View] menu, select [Rotate/Invert] → [Flip Horizontal].

Rotating the Canvas
If it is difficult to draw at the current angle, you can rotate the canvas to an angle that makes it easier to draw.
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Before Drawing a Work in CLIP STUDIO PAINT > Basic Canvas Operations and Shortcuts
Move the slider or click the buttons at the bottom left of the canvas window or on the [Navigator] palette.

In the [View] menu, select [Rotate/Invert] and then the desired rotation method.

Select the [Move] tool from the [Tool] palette and select the [Rotate] sub tool from the [Sub tool] palette. To rotate, drag on the canvas.

When using the touch operation for rotation on an iPad, the canvas will rotate accordingly.
CLIP STUDIO PAINT STARTUP GUIDE 20



Before Drawing a Work in CLIP STUDIO PAINT > Basic Canvas Operations and Shortcuts
List of Frequently Used Shortcuts
Shortcut keys are available for the operations described in this section to allow you to work more efficiently. Try using them.

 To use shortcut keys on an iPad, please connect a keyboard to it.

 You can also use the edge keyboard for shortcuts on the iPad. The edge keyboard lets you use modifier keys 
like Command and Shift for shortcuts. Please read the section “Edge Keyboard” for more details on how to 
use it.

Contents Windows macOS/iPad

Undo the last operation [Ctrl]+[Z] [Command]+[Z]

Fit to screen [Ctrl]+[0] (zero) [Command]+[0] (zero)

Scale up (switch to [Zoom] tool) [Ctrl]+[Space]
[Space]+[Command]

*Hold down [Space] first.

Scale down (switch to [Zoom] tool) [Alt]+[Space] [Option]+[Space]

Move (switch to [Hand] tool) [Space] [Space]

Rotating the Canvas [Shift]+[Space] [Shift]+[Space]

Clear [Delete] [Delete]

When you switch to the [Zoom] tool, you can scale up or down by dragging on the canvas as follows:

 Scale up: Drag to the right

 Scale down: Drag to the left
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Before Drawing a Work in CLIP STUDIO PAINT > Basic Canvas Operations and Shortcuts
Edge Keyboard (iPad)
When using an iPad, swipe either from the left or right edge of the screen towards the canvas to display the edge keyboard.

The edge keyboard lets you use modifier keys like Command, Space, and Shift for shortcuts. You can also assign shortcuts to keys T1 to T15. 
The number of keys displayed depends on the size and orientation of the iPad.

To hide the edge keyboard, place your finger on the edge keyboard and swipe towards the edge of the screen.

If a semi-transparent edge keyboard appears when switching the display of the edge keyboard, please swipe in 
the same direction again.

swipe

swipe
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Before Drawing a Work in CLIP STUDIO PAINT > Basic Canvas Operations and Shortcuts
Setting a Color
This section explains how to select a color for coloring or drawing.

The [Color Wheel] palette is selected by default, but you can select the [Color Set] palette by switching the tab.

When using an iPad, tap the tab to display the [Color Wheel] and [Color Set] palettes.

Selecting a Color on the [Color Wheel] Palette
On the [Color Wheel] palette, you can select the hue from the outside circle and the brightness and saturation from the inside square.

Selecting a Color on the [Color Set] Palette
On the [Color Set] palette, in addition to selecting your color from a list of typical colors, you can register frequently used colors as a [Color 
Set].
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Try Drawing an Illustra-
tion in CLIP STUDIO 
PAINT Basic Guide
This section explains the basic operations for creating illustrations using CLIP STUDIO PAINT.
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Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide

 Process for Creating an Illustration: Basic Guide
Follow the steps below to draw an illustration.

About This Tutorial
This tutorial was simplified and rearranged by CELSYS for this Startup Guide based on works by Taira Akitsu, a 
famous Japanese illustrator.

Create a layer for coloring and then color with the [Fill] 

tool, [Pen] tool or [Airbrush] tool.

Coloring

Ink the line drawing using the [Pen] tool according to "Draft".

Inking

Draw a rough version and then draw drafts according to the

rough version to determine the layout of illustrations and the 

positions of items.

Draft
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 Rough Draft
First, create a new canvas and draw a draft while thinking about what kind of illustration you want to draw. Start by
doodling and then gradually turn that into your completed image.

Creating a New Canvas

1 First, create a new canvas.
Select the [File] menu → [New] to open the [New] dialog.

In PRO or EX, start by selecting [Illustration] for [Use of work].

Select [A4] for [Standard Paper Size]. Set [Resolution] to [350dpi] and turn on [Paper color].

After creating a canvas, draw a draft while thinking about what kind of illustration you want to draw.

For details on creating a canvas and configuring the settings, see "Before Drawing a Work in CLIP STUDIO 
PAINT" →  "Preparations" .
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Preparing the Drawing Tool
A variety of drawing tools are available in CLIP STUDIO PAINT. Choose different drawing tools to suit your style and purpose.

1 Here you will use the [Pencil] tool to draw your draft. Adjust the brush size to make this 
tool easy to use.
Select the [Pencil] tool from the [Tool] palette and select "Darker pencil" from the [Sub tool] palette.

2 Adjust the brush size of the [Pencil] tool.
Adjust the brush size of the [Pencil] tool either by moving the [Brush Size] slider on the [Tool Property] palette or by selecting a size on 
the [Brush size] palette.

If these palettes are not displayed, you can display them using the [Window] menu.
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Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide > Rough Draft
Using the drawing tools (iPad)
When using an iPad, the display method of the screen for setting up tools etc. will differ. This part will explain the steps of selecting the [Pencil] 
tool and adjusting its settings.

1 Tap the [Pencil] tool in the [Tool] palette.

2 Tap the PAINT icon. Tap the icon of the [Sub Tool] palette. When the [Sub Tool] palette is
displayed, tap on the [Darker pencil] tool.
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Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide > Rough Draft
3 Tap the icon of the [Brush Size] palette. When the [Brush Size] palette is displayed, select
a brush size.
The selected brush size will be applied to the [Darker pencil] sub tool.

4 Tap the icon of the [Tool Property] palette. When the [Tool Property] palette is displayed,
adjust the tool settings.
With the [Darker pencil] sub tool, you can adjust settings such as [Brush density] and [Stabilization].

Other tools can be selected and adjusted in the same way.

 The contents of the [Sub Tool] palette changes according to the tool selected from the [Tool] palette.

 The contents of the [Tool Property] palette changes according to the tool selected from the [Sub Tool] palette.
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Drawing a Draft

1 Select [Window] menu → [Color Set] to show the [Color Set] palette.

2 Set the line color to be used in the draft. Click light blue in the [Color Set] palette to select
it as a color.
We have chosen a color that is easy to distinguish from black as black will be used to ink the illustration later.

3 Draw a rough overall layout for the illustration.
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Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide > Rough Draft
Correcting the Lines

1 To erase lines you have drawn, use the [Eraser] tool.
 Select the [Eraser] tool from the [Tool] palette and select "Hard" from the [Sub tool] palette.

2 Adjust the size of the [Eraser] tool.
Adjust the brush size of the [Eraser] tool either by moving the [Brush Size] slider on the [Tool Property] palette or by selecting a size on 
the [Brush size] palette. Setting a larger size allows you to erase a larger area at once, while setting a smaller size allows you to correct fine 
details.

3 Move the eraser along the line to be erased.

Tips: Correcting a Line Using [Undo]
You can undo your last action while drawing by using [Undo] on the [Toolbar]. Use [Undo] to completely redraw a line or the [Eraser] tool to 
correct part of a line or an area containing multiple lines.

When using an iPad, you can undo operations by tapping the canvas with two fingers.

Drag to erase
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Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide > Rough Draft
Finishing the Draft
Start with a rough drawing and then add the fine details. Draw and erase gradually until your draft is finished.

Your draft is now complete.

You can adjust the scale and position of the canvas when drawing the fine details. For details on the display oper-
ations of the canvas, see "Before Drawing a Work in CLIP STUDIO PAINT" →  "Basic Canvas Operations and 
Shortcuts" .
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Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide > Inking
 Inking
After your draft is finished, draw the main lines using the [Pen] tool. This process is called "inking". The main lines of
the character are drawn on a different layer from the draft.

What is a Layer?
Layers are used when drawing illustrations and manga with digital painting tools such as CLIP STUDIO PAINT. A layer is something similar 
to a transparent piece of film. All elements, such as lines and color, are drawn on these transparent layers. The canvas shows the result of all of 
the layers stacked together.

Drawing elements such as lines, color, characters and background on different layers allows you to edit each element separately. Separating ele-
ments into layers allows various operations for efficient editing, such as hiding the draft once it is no longer needed, keeping the lines while 
refilling the color and changing the position of the character relative to the background.

The [Layer] palette shows the layers in order from the top downward. When "Normal" is set as the blending mode, lower layers cannot be seen 
through the content on the layers above.
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Tips: When displaying the layer palette on the iPad
When using an iPad, tap the icon on the [Layer] palette to display the palette.
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Creating a Layer
Create a layer for a line drawing. Drawing this on a separate layer from the draft is convenient as it allows you to change the data so that only 
the line drawing shows, simply by hiding the draft layer.

1 On the [Layer] palette, double click the layer name of the layer containing the draft ("Layer 
1") and change the name to "Draft".

2 Move the [Opacity] slider on the [Layer] palette down to "50" to lighten the color of the
draft.
Lowering the opacity of the draft makes it easier to see the inking lines.

3 Click [New Raster Layer] on the [Layer] palette to create a new layer.
The currently selected layer is indicated by changing the color of the layer name to blue.

Double click

the layer name

Click

[New Raster Layer]
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4 Double click the layer name and enter "Line drawing".

Preparing the Pen Tool
Inking is done with the [Pen] tool. Adjust the [Pen] tool before starting.

1 Select the [Pen] tool from the [Tool] palette and select [Mapping pen] from the [Sub tool] 
palette.

2 Adjust the brush size of the [Pen] tool.
 Adjust this on the [Tool Property] palette or select a size from [Brush Size].

3 Click black in the [Color Set] palette to select it as a color.

Double click
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Inking the Drawing
Draw the lines, using the draft as a guide. First, draw the outline of the character and the outlines of each part.

Because you created the "Line drawing" layer on top of the "Draft" layer, the blue lines of the draft are covered by the black inked lines.

You can add variance for decorative lines such as wrinkles in the character's clothing by drawing with a lighter pen pressure to create finer 
lines.

Correcting the Lines
To correct lines, use the [Eraser] tool.

1 On the [Tool] palette, select the [Eraser] tool. On the [Sub tool] palette, select [Hard].
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2 Adjust the size of the [Eraser] tool.
Adjust the brush size of the [Eraser] tool either by moving the [Brush Size] slider on the [Tool Property] palette or by selecting a size on 
the [Brush size] palette.

3 Move the eraser along the line to be erased.

Erasing the main lines will not erase the blue lines in the draft, as the draft is on a different layer.

Ink the drawing using the [Pen] tool and the [Eraser] tool.

Drag to erase
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Drawing the Fine Details
Once the overall outline is complete, create a new layer for the lines of the patterns on the clothes and wings.

1 Click [New Raster Layer] on the [Layer] palette to create a new layer.
Double click the layer name of the layer you have created and enter "Fine line".

2 Adjust the brush size of the [Pen] tool using the [Brush Size] slider or the [Brush Size] pal-
ette on the [Layer Property] palette.
Make the brush size slightly finer than the size used to draw the outline.

3 Draw the patterns on the clothing and wings.
Drawing these areas on a separate layer from the outline makes it easier to correct areas where the lines of the pattern overlap with those of 
the outline.
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Finish Inking the Drawing
Once inking is complete, hide the "Draft" layer so that only the main lines can be seen.

1 Click [Show/hide layer] to the left of the "Draft" layer on the [Layer] palette to hide the 
layer.

2 The draft layer is hidden and only the main lines are displayed. Inking is now complete.
Unlike when drawing on paper, the draft lines do not need to be erased as the use of separate layers allows this to be done automatically by 
hiding the draft layer.
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 Basic Coloring
Add color to your illustration.

Use the [Fill] tool and the [Pen] tool for basic coloring. Use a separate layer for each part of the illustration so that you
can color without having to deal with runover in later processes.

Coloring the Hair
Create a layer and color the character's hair using the [Fill] tool.

Preparing the Layers
Create a layer for coloring.

1 Click [New Raster Layer] on the [Layer] palette to create a layer.
Double click the layer name of the layer you have created and enter "Hair".

2 Move the "Hair" layer below the "Line drawing" layer so that the main lines are not covered
up by the hair color.
Click the layer name area of the "Hair" layer and drag the layer below the "Line drawing" layer.
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3 Click [Show/hide layer] to the left of the "Fine line" layer on the [Layer] palette to hide the
layer.
Hide the "Fine line" layer for now, as this stage is for coloring the larger areas and the fine details are not needed. This allows you to fill 
large areas all at once with the [Fill] tool.

Preparing the Tool
Configure the settings for coloring with the [Fill] tool.

1 Select the [Fill] tool from the [Tool] palette and select [Refer other layers] from the [Sub 
tool] palette.

2 Move the slider in [Area scaling] on the [Tool Property] palette to "1".

In this example, [Area scaling] has been set to a low value because a high value would cause the color to run over. 
For details on [Area scaling], see " CLIP STUDIO PAINT Tool Setting Guide" → "Settings List" → "Fill".
CLIP STUDIO PAINT STARTUP GUIDE 42

https://www.clip-studio.com/site/gd_en/csp/toolguide/


Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide > Basic Coloring
3 Check that [Multiple referring] is turned on on the [Tool Property] palette.

Tips: Layer References
The [Fill] tool usually determines the area to be filled according to the content drawn on the currently selected layer. If separate layers are used 
for the line drawing and color like in this example, the content drawn on the line drawing layer will be ignored. To overcome this problem, you 
can set [Multiple referring] on the [Tool Property] palette to reference the content drawn on other layers.

The [Refer other layers] function of the [Fill] tool references all displayed layers when filling. If the draft is displayed, the lines of the draft will 
also be referenced. Make sure to hide any finished layers that will not be used.

but nothing is drawn

in the selected layer

The line drawing appears to exist

Hide "Draft"
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Adding the Basic Color
Fill in the basic colors using the [Fill] tool.

1 Select [Window] menu → [Color Wheel] to show the [Color Wheel] palette.

2 Select pink for the hair color on the [Color Wheel] palette.
Use the [Color Wheel] palette to select colors that are not on the [Color Set] palette. Use the circle on the outside (1) to select the hue and 
the square at the center (2) to adjust the brightness and the saturation (how vivid the color should be).

3 Click the area to be filled with the [Fill] tool. The entire area surrounded by the lines is
filled.

4 Follow the same steps to fill other areas of the hair.
Areas where shadow will be added later should also be filled with the basic color.

Areas divided into fine tufts of hair can be filled at the same time by dragging instead of clicking each area.

Drag the [Fill] tool

to fill continuously
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Tips: If Problems Occur When Filling
CLIP STUDIO PAINT's [Fill] tool has a [Close gap] function that will recognize and fill an enclosed area even if there is some line breakage. 
If the [Fill] tool fills too far, this means that a line is broken somewhere.

Undo the filling by selecting the [Edit] menu → [Undo], then select the "Line drawing" layer and connect the broken line(s) using tools such as 
the [Pen] tool. After correcting the lines, fill the area again using the [Fill] tool.

Adding Shadow
Use the [Fill] tool or the [Pen] tool to add shadow to the hair.

1 Select a slightly darker shade of pink on the [Color Wheel] palette.

2 Click to fill the tufts of hair on which to add shadow.

Lines are broken

Correct with the pen tool
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3 To fill an area without the necessary border lines, either color the area directly using the
pen tool or draw a border line before using the [Fill] tool to add shadow to the area.

Coloring Unfilled Areas
The [Fill] tool cannot fill small areas such as the tips of the hair or areas where lines intersect. Use the [Pen] tool to color these unfilled areas.

1 Select the [Pen] tool from the [Tool] palette and select [Mapping pen] from the [Sub tool] 
palette.

2 Adjust the brush size of the [Pen] tool.
Adjust the brush size to suit the size of the area to be colored.

Draw borders with tools such as the pen
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3 Color the small areas with the [Pen] tool so that no gaps remain.

4 Coloring of the hair is now complete.

You can also color small unfilled areas by using the [Close and fill] sub tool of the [Fill] tool. For details on [Close 
and fill], see "CLIP STUDIO PAINT Tool Setting Guide" → "Tool and Sub Tool Categories" → "Fill (Close and Fill)".
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Tips: Obtaining the Same Color as the Filled Color
While a drawing tool such as the [Pen] tool is selected, hold down the [Alt] key on the keyboard to switch to the [Eyedropper] tool temporarily. 
Click the canvas while holding down [Alt] to acquire the color of the clicked area as the drawing color. This makes it easy to select the same 
color as the existing basic color or shadow color when making corrections or coloring unfilled areas. The color can also be acquired by select-
ing the [Eyedropper] tool on the [Tool] palette.

Coloring the Skin
Create a layer and color the character's skin using the [Fill] tool.

Adding the Basic Color of the Skin
Create a new layer for coloring the skin and fill the drawn areas with the basic skin color.

1 Click [New Raster Layer] on the [Layer] palette. Double click the layer name of the layer 
you have created and change the layer name to "Skin".

2 Select the [Fill] tool from the [Tool] palette and select [Refer other layers] from the [Sub
tool] palette. Check that [Multiple referring] is turned on on the [Tool Property] palette.

Here we will configure the same settings for this tool as when coloring the hair. For details, see →  "Basic Color-
ing"  →  "Coloring the Hair"  →  "Preparing the Tool" .

[Alt] + click to acquire

the color of the clicked area
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3 Select peach for the skin color on the [Color Wheel] palette.

4 Click to fill the areas of exposed skin.

5 Use the [Pen] tool to color small unfilled areas.
Use the [Pen] tool to color areas that are unfilled because there are a lot of lines, such as the ears and the areas around the eyes.

6 The entire skin area has now been filled with the main color.
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Adding Shadow (Without Runover)
Use the areas you filled with the main skin color before to draw the shadow on the skin.

1 Click [Lock Transparent Pixel] on the [Layer] palette.
An icon with a gray padlock and a checkered square appears next to the layer on which the transparent pixels are locked.

2 Select a slightly darker color than peach on the [Color Wheel] palette.
A more reddish hue will stop the shadow from looking somber and give the character a healthy-looking complexion.

3 Select the [Pen] tool from the [Tool] palette and select [G-pen] from the [Sub tool] palette.

This icon indicates that

the transparent pixels are locked
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4 Adjust the brush size of the [Pen] tool.
Adjust this in [Tool Property] or select a size from [Brush Size]. Set a slightly larger brush size than when drawing the lines to allow even 
coloring.

5 Draw the shadows around the neck and those created by the sleeves and hair.

6 If you draw shadow too far, correct it by applying the basic skin color using the [Pen] tool.
 The [Eraser] tool cannot be used in this case as it will also erase the peach color underneath.

7 When drawing the shadow around the eyes, use the [Color Wheel] palette to select a
slightly lighter shade than the other skin shadows so that this area is not too dark.
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Tips: What Is the [Lock Transparent Pixel] Function?
This function ensures that nothing is drawn in the transparent areas (on the transparent pixels) of the layer.

This allows you to add shadow without running over onto areas that have already been colored, such as the hair, or the skin in later steps.

Adding a Gradient on the Skin
To give the skin a softer look, add a gradient using the [Airbrush] tool.

1 Select the [Airbrush] tool from the [Tool] palette and select [Soft] from the [Sub tool] pal-
ette.

2 Adjust the brush size of the [Airbrush] tool to a larger size.

3 Select the color you used around the eyes on the [Color Wheel] palette.

        indicates

transparent pixels

It is usually possible to
draw on transparent pixels...

When "Lock Transparent Pixel"
is performed, it is not possible
to draw on transparent pixels
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4 Use the blurred edges of the brush to create a gradient on the skin. Use a light pen pres-
sure.
The color will not run over even if you use a large brush size, as [Lock Transparent Pixel] is set. If the color is too light, draw across the 
same area several times.

5 Coloring of the skin is now complete.

A larger brush size

creates a softer blur
CLIP STUDIO PAINT STARTUP GUIDE 53



Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide > Basic Coloring
Coloring the Wings
Create a new layer and use tools such as the [Fill] tool and the [Gradient] tool to color the wings.

Adding the Basic Color of the Wings
Create a new layer for coloring the wings and fill the drawn areas with the basic color.

1 Click [New Raster Layer] on the [Layer] palette. Double click the layer name of the layer 
you have created and change the layer name to "Wings".

2 Select the [Fill] tool from the [Tool] palette and select [Refer other layers] from the [Sub
tool] palette.
Check that [Multiple referring] is checked on the [Tool Property] palette.

3 Select light blue on the [Color Wheel] palette.

Here we will configure the same settings for this tool as when coloring the hair. For details, see →  "Basic Color-
ing"  →  "Coloring the Hair"  →  "Preparing the Tool" .
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4 Click to fill the areas of the wings.

5 Select blue on the [Color Wheel] palette and fill the bones, trailing edges and shadows of
the wings.
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6 Use the [Pen] tool to color small unfilled areas.

Coloring with the [Gradient] Tool 1
Create a selection for each part and add a gradient to the wings using the [Gradient] tool.

1 Select the [Auto select] tool from the [Tool] palette and select [Refer to all layers] from the 
[Sub tool] palette.

2 Click the bones of the wings and select the area in which to apply the gradient.

If the [Gradient] tool is used without creating a selection, it will draw a gradient across the entire layer. Creating a 
selection first allows you to apply a gradient across the selected area only.

For details on the [Auto select] tool, see "CLIP STUDIO PAINT Tool Setting Guide" → "Tool and Sub Tool Catego-
ries" → "Input/Output Process / Category List (by Tool/Sub Tool)" → "Auto select".

Click to select
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3 If the bones are separated into multiple segments in the line drawing and cannot be
selected with one click, hold down the [Shift] key and click each segment to add the seg-
ments to the selection.

4 Select the [Gradient] tool from the [Tool] palette and select [Foreground to transparent]
from the [Sub tool] palette.

The [Foreground to transparent] setting creates a gradient from the selected drawing color to transparency. If it is applied to an area that 
has already been filled, this creates a gradient from the current drawing color to the ground color.

5 Select a slightly lighter shade of blue on the [Color Wheel] palette.

[Shift] + click to make additional selections
CLIP STUDIO PAINT STARTUP GUIDE 57



Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide > Basic Coloring
6 Click the starting position of the gradient and drag in the direction in which to apply the
gradient.

7 After creating the gradient, click the [Selection] menu → [Deselect] to deselect the
selected area.
This can also be done by selecting [Deselect] on the command bar or the selection launcher.

8 Repeat the same process for other areas such as the trailing edges, creating selections
and drawing gradients for each part.

Drag to create gradient
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Coloring with the [Gradient] Tool 2
Next, apply a gradient to the light blue part of the wings.

1 Click [Show/hide layer] to the left of the "Fine line" layer on the [Layer] palette to show the 
layer.

The hidden fine lines are shown again, allowing fine areas to be specified.

2 Select the [Auto select] tool from the [Tool] palette and select [Refer to all layers] from the
[Sub tool] palette.
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3 Click to select the area in which to apply the gradient.
To apply one gradient across multiple areas, hold down the [Shift] key and click each area to add the areas to the selection.

4 Select the [Gradient] tool from the [Tool] palette and select [Foreground to transparent]
from the [Sub tool] palette.

5 Select a slightly darker color than the light blue area on the [Color Wheel] palette.
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6 Draw the gradient by dragging in the direction in which to create the gradient.

7 Repeat the same process to draw a gradient in other areas of the wings.

8 Coloring of the wings is now complete.

Drag to create gradient
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Coloring the Clothing
Color the remaining parts, such as the character's clothing and hair ornaments.

Coloring the White Background (Show Transparent Area)
If you fill a white background (paper) with a white drawing color, it will be difficult to tell the white filled area apart from the area that is dis-
played in white but is actually transparent. This may cause areas to remain unfilled or runover to occur. To prevent this problem, hide the paper 
layer during this operation so that the transparent area can be recognized.

1 Click [New Raster Layer] on the [Layer] palette to create a layer. Double click the layer 
name of the layer you have created and change the layer name to "Clothing 1".

2 Click [Show/hide layer] to the left of the "Paper" layer on the [Layer] palette to hide the
layer.

The areas in which no layers have been colored are indicated by a checkered pattern.

Transparent
CLIP STUDIO PAINT STARTUP GUIDE 62



Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide > Basic Coloring
3 Select the [Fill] tool from the [Tool] palette and select [Refer other layers] from the [Sub
tool] palette. Check that [Multiple referring] is turned on on the [Tool Property] palette.

4 Select a yellowish white on the [Color Wheel] palette.

5 Click to fill the white fabric of the clothing with the [Fill] tool.

6 Fill the shadow areas with pale blue.

Here we will configure the same settings for this tool as when coloring the hair. For details, see →  "Basic Color-
ing"  →  "Coloring the Hair"  →  "Preparing the Tool" .
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7 Once all of the white area has been filled, click [Show/hide layer] to the left of the "Paper"
layer on the [Layer] palette to show the layer.

Coloring the Other Areas
Add a layer and color the other parts of the clothing.

1 Click [New Raster Layer] on the [Layer] palette to create a layer. Double click the layer 
name of the layer you have created and change the layer name to "Clothing 1".

2 Select the [Fill] tool from the [Tool] palette and select [Refer other layers] from the [Sub
tool] palette. Check that [Multiple referring] is turned on on the [Tool Property] palette.

3 Hide the "Fine line" layer temporarily on the [Layer] palette to fill the whole of large areas
at once.

Here we will configure the same settings for this tool as when coloring the hair. For details, see →  "Basic Color-
ing"  →  "Coloring the Hair"  →  "Preparing the Tool" .
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4 Select the drawing color on the [Color Wheel] palette and add the base color of the stole
using the [Fill] tool.

5 After coloring is finished, show the "Fine line" layer again on the [Layer] palette.

6 Select the drawing color on the [Color Wheel] palette and add the colors of the checkered
pattern using the [Fill] tool.
Create a layout of dark and light colors according to the base color and use these colors to color the checkered pattern.
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7 Fill other areas such as the boots and hair ornament by selecting a drawing color on the
[Color Wheel] palette and coloring with the [Fill] tool.
Give the hair ornament depth by using progressively darker colors for the back parts.

8 Select the [Pen] tool in the [Tool] palette and color unfilled areas and areas that cannot be
colored with the [Fill] tool because there are no border lines.
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9 The clothing is now colored.
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 Drawing the Fine Details
Now that all the large areas have been colored, finish the character by drawing the fine details of the illustration such
as the eyes and highlights.

Drawing the Eyes (Combine Layers)
Create each part of the eyes on a separate layer and finish by joining the layers.

Drawing the White of Eye

1 Click [New Raster Layer] on the [Layer] palette to create a layer. Double click the layer 
name of the layer you have created and change the layer name to "White of eye".

2 Change the stacking order of the layers with the [Layer] palette.
On the [Layer] palette, drag the "White of eye" layer so that it is immediately above the "Skin" layer.

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move 
it. For details, please refer to  "Tips: When unable to move layers on the iPad." .

Drag to change the stacking

order of the layers
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Move the "Hair" layer so that it is above the "White of eye" layer. This places the eye layer below the hair so that drawing the eye does not 
affect the hair covering it.

3 Select the [Pen] tool from the [Tool] palette and select [G-pen] from the [Sub tool] palette.

4 Select white on the [Color Wheel] palette and color the whites of the eyes with the [Pen]
tool.

5 Select a slightly darker color than white on the [Color Wheel] palette and color the shadow
area with the [Pen] tool.
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Tips: When unable to move layers on the iPad.
If you want to move a layer from the [Layers] palette to change the stacking order of layers etc., drag and drop the layer to the position where 
you want to move it.

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move it. 
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Drawing the Eyelashes

1 Click [New Raster Layer] on the [Layer] palette to create a layer. Double click the layer 
name of the layer you have created and change the layer name to "Eyelashes".

2 Select dark brown on the [Color Wheel] palette and color the eyelashes with the [Pen] tool.

Blur part of the eyelashes by using the [Airbrush] tool in a lighter color so that the color of the eyelashes is not too strong.

3 Click [Lock Transparent Pixel] on the [Layer] palette.
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4 Select the [Airbrush] tool from the [Tool] palette and select [Soft] from the [Sub tool] pal-
ette.

5 Adjust the brush size of the [Airbrush] tool.
Adjust this on the [Tool Property] palette or select a size from the [Brush size] palette.

6 Select a slightly lighter brown on the [Color Wheel] palette and trace along the tops of the
eyelashes with the [Airbrush] tool to add a gradient.
Changing the color like this will not cause runover from the eyelashes as [Lock Transparent Pixel] is set.

Paint over with brown

using the [Airbrush] tool
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Coloring the Eye (Irises/Pupils)

1 Click [New Raster Layer] on the [Layer] palette to create a layer. Double click the layer 
name of the layer you have created and change the layer name to "Eye".

Make sure that the "Eye" layer is above the "White of eye" layer. If the "White of eye" layer is above the "Eye" layer, drag the "Eye" layer 
so that it is above the "White of eye" layer on the "Layer" palette.

2 Select the [Pen] tool from the [Tool] palette and select [G-pen] from the [Sub tool] palette.

3 Select light blue on the [Color Wheel] palette and color the colored parts of the eyes with
the [Pen] tool.

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move 
it. For details, please refer to  "Drawing the White of Eye" → "Tips: When unable to move layers on the iPad." .
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4 Select a slightly darker color than the light blue base color on the [Color Wheel] palette
and color the darker areas of the colored parts of the eyes with the [Pen] tool.

5 Click [Lock Transparent Pixel] on the [Layer] palette.

6 Select the [Airbrush] tool from the [Tool] palette and select [Soft] from the [Sub tool] pal-
ette.

7 Adjust the brush size of the [Airbrush] tool.
Adjust this in [Tool Property] or select a size from [Brush Size].
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8 Select a brighter light blue color on the [Color Wheel] palette and trace along the bottoms
of the colored parts of the eyes with the [Airbrush] tool to add a gradient.

Joining the Layers
Due to the drawing method, the eyes are made up of three different layers. Join these into one layer for easier management.

1 On the [Layer] palette, click the left area of the "White of Eye" and "Eyelashes" layers so 
that a check mark appears. The "Eye", "White of eye" and "Eyelashes" layers are now all 
selected.

2 Select [Layer] menu → [Combine Selected Layer].
The "Eye", "Eyelashes" and "White of eye" layers are joined as one layer. The layer name is "Eye", as this layer was selected while per-
forming this operation.

You can use this function to organize layers by joining them if there are too many layers or if you have finished drawing some layers. 
Note, however, that once layers have been joined, they can only be separated by using the [Undo] function.

Click to select

multiple layers
CLIP STUDIO PAINT STARTUP GUIDE 75



Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide > Drawing the Fine Details
Drawing Highlights
Finally, add highlights to the entire illustration to add depth. Place the highlight layer above the line drawing to make the highlights more lus-
trous.

1 Click [New Raster Layer] on the [Layer] palette to create a layer. Double click the layer 
name of the layer you have created and change the layer name to "Highlight".

2 On the [Layer] palette, move the "Highlight" layer so that it is above the line drawing layer
and all of the other layers.

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move 
it. For details, see  "Drawing the Fine Details"  →  "Drawing the Eyes (Combine Layers)"  →  "Drawing the White of 
Eye"  →  "Tips: When unable to move layers on the iPad." .

Change the stacking order

to move the layer to the top
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3 Select the [Pen] tool from the [Tool] palette and select [G-pen] from the [Sub tool] palette.

4 Adjust the brush size of the [Pen] tool.
Adjust this in [Tool Property] or select a size from [Brush Size]. Set a slightly thick size for the pen tool so that you can make use of the 
pen pressure when coloring.

5 Select white on the [Color Wheel] palette and add highlights to areas such as the wings
and hair, adjusting the brush size as appropriate.

6 If you make a mistake or color too far, correct the shape using the [Eraser] tool.
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7 Once you have finished drawing the highlights, the basic coloring of the character is com-
plete.
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Saving the Illustration
Select the [File] menu → [Save] to save the data of the completed illustration.

To keep the layers you have created, save the data in "CLIP STUDIO FORMAT file" (extension: .clip).

Selecting [Save] will save automatically, when using the iPad version. To change the file name when saving, select the [File] menu → [Save 
As].

In this section, you have learned how to color a character using the basic functions. These functions are enough to draw anime style illustrations 
with comparatively flat coloring.

In the Advanced Guide, you will learn how to use the functions of CLIP STUDIO PAINT to give the illustration a more textured finish.

To open a saved file, select the [File] menu →[Open file].
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Tips: Formats for Saving Files
To publish your illustration online or in other media, select the [File] menu → [Export (Single Layer)] to save the file in formats such as JPEG 
or PNG.

The A4-sized, 350dpi canvas used in this example is too large to publish online in its current form. Reduce the size in the [Export settings] dia-
log box before exporting the data. You can view a preview showing how the exported data will look after changing settings such as the size by 
checking [Preview rendering result on output].
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Try Drawing an Illustra-
tion in CLIP STUDIO 
PAINT Advanced Guide
This section explains how to touch up illustration data created according to the "Basic Guide" to create a back-
ground or add texture to the illustration.



Try Drawing an Illustration in CLIP STUDIO PAINT > Process for Creating an Illustration: Advanced Guide
Try Drawing an Illustration in CLIP STUDIO PAINT

 Process for Creating an Illustration: Advanced Guide
Follow the steps below to draw an illustration.

About This Tutorial
This tutorial was simplified and rearranged by CELSYS for this Startup Guide based on works by Taira Akitsu, a 
famous Japanese illustrator.

Use the materials to create backgrounds for the illustrations 

and finish the illustrations with the filter.

Finish

Adjust all colors and contrast in characters.

Tonal Correction

Add texture to fine details using clipping in the fill division 

ranges created according to the basic manual.

Add brush touches or texture
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 Touching Up a Work Using the Clipping Function
Use the clipping function to add fine details to the hair in the illustration created in the Basic Guide.

Preparing the Layer (Setting the Clipping Mask)
Set a [Clipping Mask] for the new layer you have created.

1 Click the [Layer] palette → [New Raster Layer]. Double click the layer name of the layer you 
have created and change the layer name to "Retouch hair".
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Try Drawing an Illustration in CLIP STUDIO PAINT > Touching Up a Work Using the Clipping Function
2 Change the stacking order on the [Layer] palette so that the "Retouch hair" layer is imme-
diately above the "Hair" layer.

Hide the "Highlight" layer so that the line drawing can be easily seen when coloring.

3 While the "Retouch hair" layer is selected on the [Layer] palette, click [Clip at Layer
Below].

The "Retouch hair" layer is clipped to the "Hair" layer and a red vertical line appears next to the thumbnail.

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move 
it. For details, see  "Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide"  →  "Drawing the Fine Details"  
→  "Drawing the Eyes (Combine Layers)"  →  "Tips: When unable to move layers on the iPad." .

The "Hair" layer

after clipping
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Tips: What Is Clipping at Layer Below?
Clipped layers reference the drawn area on the layer immediately below so that the selected layer is only displayed within this area. The content 
drawn on the clipped layer is not displayed in undrawn areas (transparent pixels) on the layer below. This is useful when you want to add 
shadow or touch up the drawn area on another layer. If the layer set as the reference for clipping (the "Hair" layer in this example) is hidden, the 
content drawn on the clipped layer (the "Retouch hair" layer in this example) is also not displayed.

Preparing the Drawing Tool
Three main tools are used for hair touchups: the [G-pen] sub tool of the [Pen] tool, the [Opaque watercolor] sub tool of the [Brush] tool and the 
[Soft] sub tool of the [Airbrush] tool. Change the [Brush Size] setting as needed while drawing.

Use the [Soft] sub tool of the [Airbrush] tool to apply a smooth gradient in some areas. Set a large brush size, as you will be blurring a large 
area.

Use the [G-pen] sub tool of the [Pen] tool to create a sharp division between two colors. Set a slightly large brush size as you will be coloring.

The [Opaque watercolor] sub tool of the [Brush] tool creates a comparatively clear division between colors, but gives a softer impression than 
the [Pen] tool as you can vary the darkness of the color according to the pen pressure and mix the painting color with the ground color. Mixing 
the colors creates uneven color distribution, allowing you to intentionally leave brush strokes.

Before clipping After clipping

*Example when colored only with the [Airbrush] tool

*Example when colored only with the [Pen] tool
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Touching Up Shadows 1
Touch up the hair by using the different tools to create different touches.

1 Select the [Airbrush] tool on the [Tool] palette and select [Soft] from the [Sub tool] palette.

2 Obtain a slightly more purplish color than the shadow color of the hair on the [Color Wheel]
palette.

This can be done easily by using the [Eyedropper] tool to acquire the shadow color of the hair and then changing 
the color on the [Color Wheel] palette.

*Example when colored only with the [Opaque watercolor] tool
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3 Using the large brush size that you set for the [Soft] sub tool of the [Airbrush] tool, apply a
gradient throughout the area, paying attention to the curved lines of the hair.

This will not appear outside the drawn area of the hair as this layer is clipped.

4 To create clear border lines for areas such as tufts of hair, draw with the [Pen] tool and
erase with the [Eraser] tool to add distinctions.

5 To smooth a border line added to create a distinction, use the [Opaque watercolor] sub tool
to blur the border line.

Tips: Using [Transparent color]
Setting [Transparent color] as the drawing color allows you to erase or lighten drawn content by touching the area with the current drawing 
tool. Use this along with the [Eraser] tool for smooth correction of illustrations.

Use the [Pen] tool to

create vivid outlines

Area where [Opaque watercolor]

was used
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Touching Up Shadows 2
Draw over the shadow areas of the hair in purple again to deepen the color. To confine the touchup to an even smaller area than the clipped 
area, use the [Auto select] tool to create a selection and then draw inside the selected area.

1 Select purple on the [Color Wheel] palette.

2 On the [Tool] palette, select the [Auto select] tool → [Refer to all alyer].

3 Click the area of the canvas on which to draw.
To color multiple areas at once, hold down the [Shift] key while clicking each area of the canvas to create additional selections.

Create a selection for

the area to be drawn
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4 Set the desired darkness of the color (degree of mixing) by drawing with the [Opaque
watercolor] sub tool of the [Brush] tool, adjusting the pen pressure to obtain the desired
darkness.

After you have finished drawing, click the [Selection] menu → [Deselect] to deselect the selected area.

5 Adjust the drawing color slightly and repeat the steps above to add color to other areas.

Tips: Adding Depth to a Color
One way of adding depth to a color is to add similar colors in different hues instead of simply adding lighter and darker shades of the same 
color. Another method is to pay attention to ambient light in the character's surroundings and light reflected off nearby objects and mix these 
colors into the other colors throughout the image.
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Tips: If Problems Occur When Creating Selections
The [Refer other layers to select] sub tool of the [Auto select] tool also refers to the content on layers currently being drawn. This may cause 
problems when selecting areas that have already been drawn. In this case, temporarily hide unnecessary layers before creating a selection. In 
the example shown below, the "Retouch hair" layer is hidden as it is currently being drawn.

You can also configure the settings on the [Tool Property] palette of the [Auto select] tool so that edited layers are not referenced.

Already filled areas are

also referenced, resulting in

an incomplete selection

Temporarily hide

the layer and create

the selection

Not refer editing layer

Click to expand the items
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Touching Up the Highlights
Increasing the shadow areas will make the illustration look a little dark. Add another layer and add light areas to balance the illustration out.

1 Click [New Raster Layer] on the [Layer] palette to create a layer.
Double click the layer name of the layer you have created and change the layer name to "Luster of hair".

2 While the "Luster of hair" layer is selected, click [Clip at Layer Below] on the [Layer] pal-
ette.

The "Luster of hair" layer is clipped to the "Hair" layer along with the "Retouch hair" layer and a red vertical line appears next to the 
thumbnail. In this case, the "Luster of hair" layer is clipped to the drawn area of "Hair" layer, not the "Retouch hair" layer immediately 
below the "Luster of hair" layer.

3 Select a yellowish white on the [Color Wheel].

4 Using the [G-pen] sub tool of the [Pen] tool, draw highlights along the hair.
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5 Add light purple highlights in areas where light would be reflected, including in the shadow
areas.

Touching Up the Reflected Light
Add blue light reflected from the wings to the hair. Rather than drawing the reflected light realistically, add this touchup so that the color of the 
hair is not obtrusive when looking at the overall picture.

1 Select the [Brush] tool from the [Tool] palette and select [Dense watercolor] from the [Sub 
tool] palette.
Set the brush size to around "170" on the [Tool Property] palette, etc.

2 Select light blue on the [Color Wheel] palette and draw on the "Luster of hair" layer.

Add reflected light to wing colors
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3 Like in the previous processes, use the [Soft] sub tool of the [Airbrush] tool to make the
color soft and blurry in some areas.

4 Touchup of the hair is now complete.

Use [Airbrush] for

a smooth gradient
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 Touching Up Using the [Blending mode] of the 
Layers

Shadow is added to the clothing using the [Blending mode] of the layers. Changing the [Blending mode] of the layers
allows you to apply various effects to areas where the color overlaps with layers below.

Drawing Shadow Using the "Multiply" Blending Mode
Add shadow using a layer whose [Blending mode] is set to [Multiply]. The content drawn on the [Multiply] layer is multiplied by the color 
value on the layer below to create a darker color, making this mode ideal for adding shadow. If the color on the layer below is pure white, there 
is no change to the color. The darker the color on the layer below, the darker the color that is created relative to the layer below.

Preparing the Layers

1 While the "Clothing 2" layer is selected on the [Layer] palette, click [New Raster Layer].
Double click the layer name of the layer you have created and change the layer name to "Clothing 2: Shadow".

2 While the "Clothing 2: Shadow" layer is selected, click [Clip at Layer Below] on the [Layer]
palette.

For details on the [Blending mode] of the layers, see "CLIP STUDIO PAINT User Guide" → "Layer Palette" → 
"Layer Operations" → "Configuring the Combine Mode".

Combine mode: Normal Combine mode: Multiply
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3 Set the [Blending mode] of the "Clothing 2" layer to [Multiply].

Click to display list
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Drawing the Shadows

1 Select the [Airbrush] tool on the [Tool] palette and select [Soft] from the [Sub tool] palette.

2 Draw a light purple gradient for the shadow, paying attention to the overall shape (round-
ness) of the stole.

3 Select the [Brush] tool from the [Tool] palette and select [Opaque watercolor] from the
[Sub tool] palette.

*Example of normal combining shown in line drawing
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Try Drawing an Illustration in CLIP STUDIO PAINT > Touching Up Using the [Blending mode] of the Layers
4 Add shadows with clear border lines along the folds of the stole.

Drawing Light Areas Using the "Screen" Blending Mode
Lighten some areas using a layer whose [Blending mode] is set to [Screen]. A color lighter than the layer below is created for the content drawn 
on the [Screen] layer, making this mode ideal for highlights and other light areas. If the color on the layer below is pure black, there is no 
change to the color. The lighter the color on the layer below, the lighter the color that is created relative to the layer below.

Preparing the Layers

1 While the "Clothing 2: Shadow" layer is selected on the [Layer] palette, click [New Raster 
Layer].
Double click the layer name of the layer you have created and change the layer name to "Clothing 2: Light".

2 While the "Clothing 2: Light" layer is selected on the [Layer] palette, click [Clip at Layer
Below].

Combine mode: Normal Combine mode: Screen
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3 On the [Layer] palette, set the [Blending mode] of the "Clothing 2: Light" layer to [Screen].

Click to display list
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Drawing the Light Areas

1 Select the [Airbrush] tool on the [Tool] palette and select [Soft] on the [Sub tool] palette.

2 Select dark red on the [Color Wheel] palette and color the left shoulder area in dark red
using the [Airbrush] tool.
While the drawn color is dark, the drawn color will be slightly lighter than the original color as the [Blending mode] is set to "Screen".

*Example of normal combining shown in line drawing
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3 Select dark purple on the [Color Wheel] palette and lightly color the right shoulder area.

4 Coloring of the stole is now complete.

Using the layer blending mode allows you to lighten, darken or deepen the colors in the illustration based on the ground color. This is par-
ticularly useful for adding shadows to patterned areas such as the stole in this example.

*Example of normal combining shown in line drawing
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Touching Up the Other Areas

Coloring the Boots
Touch up the boots on the "Clothing 2" layer. This area can be drawn directly onto the "Clothing 2" layer as no complex color divisions are 
needed.

1 Select the "Clothing 2" layer on the [Layer] palette and click [Lock Transparent Pixel].

2 Use the [Soft] sub tool of the [Airbrush] tool to draw in a light blue gradient from the toe
upward.

3 Touch up the highlights using the [G-pen] sub tool of the [Pen] tool.
CLIP STUDIO PAINT STARTUP GUIDE 101



Try Drawing an Illustration in CLIP STUDIO PAINT > Touching Up Using the [Blending mode] of the Layers
4 Using the [Refer other layers] sub tool of the [Fill] tool, fill the shadow of the skirt in a
slightly darker color.

5 Coloring of the boots is now complete.
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Coloring the Clothing
Add another layer and touch up the drawn areas of the "Clothing 1" layer using light and dark gradients.

1 While the "Clothing 1" layer is selected on the [Layer] palette, click [Create New Raster 
Layer] twice.
Two new raster layers are created.

2 Double click the layer name of each layer you have created and change the layer names to
"Clothing 1: Light" and "Clothing 1: Shadow".
Change the stacking order of the layers to "Clothing 1: Light" → "Clothing 1: Shadow" → "Clothing 1" (top to bottom).

3 On the [Layer] palette, select the "Clothing 1: Light" layer. Change the [Blending mode] of
the layer to [Screen] and click [Clip at Layer Below].

4 On the [Layer] palette, select the "Clothing 1: Shadow" layer. Change the [Blending mode]
of the layer to [Multiply] and click [Clip at Layer Below].

5 Select the [Airbrush] tool on the [Tool] palette and select [Soft] on the [Sub tool] palette.
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6 Select pale blue on the [Color Wheel] palette.

7 Select "Clothing 1: Shadow" and use the [Airbrush] tool to touch up the shadow color area
with a gradient.
In areas where the shadow color is adjacent to the white background, create a selection using the [Refer other layers to select] sub tool of 
the [Auto select] tool before drawing with the [Airbrush] tool.

After you have finished drawing, click the [Selection] menu → [Deselect] to deselect the selected area.

Draw clear border lines using the [Pen] tool.

8 When you have finished touching up the shadow areas, select pale yellow on the [Color
Wheel] palette.

Click with [Auto select]

tool to select
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Try Drawing an Illustration in CLIP STUDIO PAINT > Touching Up Using the [Blending mode] of the Layers
9 Color the white background using the [Airbrush] tool.

10When you have finished touching up the shadow areas, select the "Clothing 1: Light" layer
and use the [Airbrush] tool to touch up the lighter areas where light is reflected.

11Coloring of the clothing is now complete.

*Example of normal combining shown in line drawing
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 Touching Up the Wings
Add more layers to give the wings a luster.

Preparing the Layers

1 While the "Wings" layer is selected on the [Layer] palette, click [Create New Raster Layer] 
twice.
Two new raster layers are created.

2 Double click the layer name of each layer you have created and change the layer names to
"Wings: Shadow" and "Wings: Light".
With the working process in mind, change the stacking order of the layers to "Wings: Shadow" → "Wings: Light" → "Wings" (top to bot-
tom). In this example, we will start the touchup process from the lower layer.

3 On the [Layer] palette, select the "Wings: Shadow" layer. Change the [Blending mode] of
the layer to [Multiply] and click [Clip at Layer Below].

4 On the [Layer] palette, select the "Wings: Light" layer. Change the [Blending mode] of the
layer to [Screen] and click [Clip at Layer Below].
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5 Select the "Wings" layer on the [Layer] palette and click [Lock Transparent Pixel].

Creating Color Divisions in the Ground Color
Add light and dark areas, paying attention to the shadow areas and giving the parts depth. Add a slightly different hue to areas with solid color 
to give these areas depth.

1 Select the [Refer other layers] sub tool of the [Fill] tool and fill in the larger areas of the 
wing pattern in various colors. Use mainly blue.

2 Draw the fine areas using sub tools such as the [Opaque watercolor] sub tool of the [Brush]
tool.
Touch up these areas so that the shadow areas and the center of each part are darker.

Reflection (Light)

Light Source (Light)
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Create a gradient with slightly differing colors, fading to a light blue at the tips of the wings.

3 When you have finished filling the ground colors of the wing pattern, show the hidden
"Highlight" layer on the [Layer] palette.

In this example, the highlight is drawn first. If adding texture as shown on the next page, you can create effective 
highlights by drawing and adjusting the highlights according to the texture.
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Touching Up to Add Texture
To add transparency or luster, emphasize the variance between dark and light colors using a sub tool such as the [Soft] sub tool of the [Air-
brush] tool.

1 On the [Layer] palette, select the "Wings: Light" layer and add color to emphasize the light 
around the parts.

2 Select the "Wings: Shadow" layer and add a darker color near the highlights for even
greater contrast.
A greater contrast between the light and dark areas gives the material a greater luster.

*Example of normal combining shown in line drawing

Paint in a darker color

around the highlighting
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3 Repeat these steps to add texture to the wings.
Add to the "Wings: Light" layer to make an area lighter or add to the "Wings: Shadow" layer to make an area darker.

Adding a Pattern
Use the [Droplet] sub tool of the [Airbrush] tool to create a random pattern on the wings.

1 Select the [Airbrush] tool on the [Tool] palette and select [Droplet] on the [Sub tool] pal-
ette.

Using the initial setting of [Droplet] allows you to randomly distribute uneven drops. In this example, we will change the settings for the 
pattern of the wings.

In addition to the [Droplet] sub tool of the [Airbrush] tool, various other brushes such as the [Decoration] tool can 
be used to draw various patterns.

Droplet: Initial settings
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2 Adjust the [Brush Size] and [Particle size] on the [Tool Property] palette.
The [Brush Size] determines the area in which the droplets will be distributed and the [Particle size] determines the size of each droplet.

3 Draw the pattern of the wings, adjusting the [Brush Size] and [Particle size]. Draw the light
areas on the "Wings: Light" layer and the dark areas on the "Wings: Shadow" layer.

4 Touchup of the wing texture is now complete.
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 Adjusting the Overall Color Tone of the Character
Check the overall balance of the character and adjust the contrast.

Tonal Correction of the Skin Tone
The tone with which the skin has been colored is too dark for the rest of the image. Adjust the tone.

1 On the [Layer] palette, select the "Skin" layer.

2 Select [Edit] menu → [Tonal Correction] → [Hue/Saturation/Luminosity].
In the [Hue/Saturation/Luminosity] dialog box, set [Saturation] to "+10" and click [OK].

3 This increases the saturation of the content drawn on the "Skin" layer.

Using [Tonal Correction] allows you to adjust elements such as the brightness, saturation and color balance of 
the areas drawn on the selected layer.
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Adjusting the Overall Contrast
Place the layers used for coloring the character together in a [Layer Folder] and adjust the overall contrast of the character.

Preparing the Layer Folder

1 On the [Layer] palette, select the "Draft" layer. Click [New Layer Folder] to create a layer 
folder.
Double click the name of the layer folder you have created and change the name to "Character".

2 On the [Layer] palette, select the "Clothing 1: Light" layer. Hold down the [Shift] key and
click the "Skin" layer to select all of the layers from the "Clothing 2: Light" layer to the
"Skin" layer.

For details on layer folders, see "CLIP STUDIO PAINT User Guide" → "Menu" → "Layer Menu" → "New Layer 
Folder".

Click to create

layer folder

[Shift] + click to

select multiple layers
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3 Drag and drop the selected layers into the "Character" folder.

Click the "▼" mark next to the "Character" folder to close the layer folder.

4 While the "Character" layer folder is selected on the [Layer] palette, click [New Raster
Layer] twice.
Two new raster layers are created.

5 Double click the layer name of each layer you have created and change the layer names to
"Entire Character: Multiply" and "Entire Character: Screen".
Change the stacking order of the layers to "Entire Character: Multiply" → "Entire Character: Screen" → "Character" (from top to bottom).

Drag into the

layer folder

Click to close

the folder
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6 On the [Layer] palette, select the "Entire Character: Multiply" layer. Change the [Blending
mode] of the layer to [Multiply] and click [Clip at Layer Below].

7 On the [Layer] palette, select the "Entire Character: Screen" layer. Change the [Blending
mode] of the layer to [Screen] and click [Clip at Layer Below].

Clipping to the [Layer Folder] allows you to clip to all of the image areas in the [Layer Folder].

Drawing the Contrast

1 Select the [Airbrush] tool on the [Tool] palette and select [Soft] on the [Sub tool] palette.
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2 Adjust the overall contrast using the [Airbrush] tool with a large brush size.
When you look at the overall character, you will notice that the pink areas of the character's ponytail detract from the rest of the image. 
Lighten the color and then use the "Entire Character: Screen" layer to make the color paler.

Touch up the face area on the "Entire Character: Multiply" layer, emphasizing the contrast with vivid colors to attract attention to this area. 
Also use the "Entire Character: Multiply" layer to retouch and adjust the color in areas that are too pale as a result of drawing on the 
"Entire Character: Screen" layer.

*Example of normal combining shown in line drawing
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3 Adjustment of the overall color of the character is now complete.
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Adjusting the Line Drawing Color
The black drawn lines are too obtrusive next to the overall colors of the character. Change the line drawing color so that the lines blend better 
with the surrounding colors.

1 Select the "Line drawing" layer on the [Layer] palette and click [Lock Transparent Pixel].

2 Select the [Airbrush] tool on the [Tool] palette and select [Soft] on the [Sub tool] palette.

3 On the [Color Wheel] palette, select a color that is slightly lighter than black and is close to
the surrounding colors.
Select drawing colors that roughly match the surrounding colors, such as a dark brown for the dark areas of the hair and a grayish red for 
the areas where the hair catches the light.
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4 Trace along the line drawing with the [Airbrush] tool to change the color.

Follow the same process for the other areas, changing the color of the main lines to roughly match the surrounding colors.

5 Perform the same process for the "Fine line" layer as for the "Line drawing" layer, setting
[Lock Transparent Pixel] and then changing the color to gray with the [Airbrush] tool.

6 Color adjustment of the line drawing is now complete.
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 Finishing
Finish by drawing the background and using filters to add effects.

Creating the Background
Create a background for the illustration using materials from CLIP STUDIO PAINT.

1 While the "Draft" layer is selected on the [Layer] palette, click [New Raster Layer].
Double click the layer name of the layer you have created and change the layer name to "Background".

2 Select the [Gradient] tool on the [Tool] palette and select [Midday Sky] on the [Sub tool]
palette.
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3  Create the gradient by dragging downward from the top of the canvas with the [Gradient]
tool.

4 On the [Material] palette, select [Color pattern] → [Background] → [Nature] from the tree.

If the [Material] palette is not displayed, select the [Window] menu → [Material] → [Material (Color pattern)].

Drag to create

gradation
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5 Paste "Cloudy sky 01" by dragging it onto the canvas.

"Cloudy sky 01" is pasted at the bottom of the [Layer] palette. This means that when it is first pasted, it is blocked by the "Background" 
layer and cannot be seen.

6 Change the stacking order of the layers on the [Layer] palette so that the "Cloudy sky 01"
layer is immediately above the "Background" layer.

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move 
it. For details, see  "Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide"  →  "Drawing the Fine Details"  
→  "Drawing the Eyes (Combine Layers)"  →  "Tips: When unable to move layers on the iPad." .

Drag and drop

to the canvas

Drag and drop

to the canvas
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7 Change the "Blending mode" of the "Cloudy sky 01" layer to [Soft light].

8 The "Cloudy sky 01" layer is combined with the gradient of the background layer, produc-
ing colors resembling a blue sky.

By changing the [Blending mode] of the layer like this and combining a material with the colors of another layer, you can make the mate-
rial look completely different.

Click to display list
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Using Filters
You can use the [Radiation blur] filter to create an effect resembling the focus of a camera. This adds perspective.

1 Hide the "Cloudy sky 01", "Background" and "Paper" layers on the [Layer] palette.
The canvas now shows only the character.

2 On the [Layer] palette, select the "Highlight" layer and then select the [Layer] menu →
[Combine copies of displayed layer].
A layer called "Highlight 2" is created. This layer contains copies of all of the layers currently displayed on the canvas, combined as one 
layer.

In this example, the [Radiation blur] filter is used to give perspective to the character's wings. The [Gaussian blur] 
filter can also be used to make the wings blend in with the background.
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3 Show the "Cloudy sky 01", "Background" and "Paper" layers that were hidden on the
[Layer] palette.

4 While the "Highlight 2" layer is selected, select the [Filter] menu → [Blur] → [Radiation
blur].
Drag the red "X" mark displayed on the canvas to a position near the character's face.

In the [Radiation blur] dialog box, set [Area to blur] to "5" and click [OK].

Blurring centers on the character's face and grows progressively greater further away in areas such as the wings and hair.

Checking [Preview] allows you to view a preview of the filter effect. This may take time, as the [Radiation blur] fil-
ter is applied by a complex process.

Drag the X to set the

center of the blurring
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5 In the [Layer] palette, change the layer name of the "Highlight 2" layer to "Blur" and change
the [Opacity] to "30".

Lowering the opacity of the layer to which [Radiation blur] is applied makes it possible to see the "Character" folder below and adjust the 
appearance of the blur.
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6 The illustration is complete.
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Saving the Illustration
The illustration is now complete! Save your completed illustration.

To overwrite the illustration you created according to the Basic Guide, select the [File] menu → [Save]. To keep the original file and save the 
illustration under a new name, select the [File] menu → [Save as].

 For details on saving files, see "Draw a Manga in CLIP STUDIO PAINT: Monochrome Guide" →  "Saving the 
File" .

 To open a saved file, select the [File] menu →[Open file].
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 Note
In this example, the touchups had a comparatively distinct anime style. Various other touches can be added to illustra-
tions using CLIP STUDIO PAINT. You can customize your brushes and materials for even greater variety of expression.

Use sub tools such as the [Oil paint] brush of the [Brush] tool to leave brush strokes when 
coloring your illustration.

Add texture to the paper in an illustration with a watercolor finish.
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Monochrome  Manga 
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This section explains how to draw a manga draft that will be printed.



Try Drawing a Manga in CLIP STUDIO PAINT Monochrome Manga Guide [PRO/EX] > Process for Creating a Monochrome Manga Draft
Try Drawing a Manga in CLIP STUDIO PAINT Monochrome Manga Guide [PRO/EX]

 Process for Creating a Monochrome Manga Draft
Follow the steps below to draw a monochrome manga draft.

Decide on a storyboard that will serve as a blueprint before 

drawing the manga.

The storyboard is drawn to solidify content such as the story

and composition in the general picture.

Sound Effects Lettering/White

Filling in Monochrome/Tone/Gradient
Create separate layers for filling in monochrome, tone and gradient

and fill the areas in which to express these.

Draw Sound Effects Lettering, etc. using tools such as the pen.

Draw the edges in white to finish the manga.

When the manga is completed, save the data.

Dialog/Balloons/Draft
Input dialog using the [Text] tool.

Use the Balloon layer to create balloons.

Create drafts by creating a separate draft layer and drawing on it.

Borders/Inking/Effect Lines
Create frame borders by creating a [Frame Border folder] 

and then drawing borders.

Create a layer for each part, such as characters, background and 

effect lines, and ink them with the pen according to the draft.

Create new/Storyboard
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 Creating a New Manga and Storyboard
Before creating a draft for your manga, draw a storyboard. The storyboard is a rough picture that is used to determine
the story and composition.

Preparing the Manga and Creating a New File
First, create a new canvas with settings appropriate for a monochrome manga.

1 Select the [File] menu → [New].
Select [Comic] from [Use of work] in the [New] dialog box. Configure settings such as the size and select [A4 Monochrome (600dpi)] 
from [Preset]. The other settings have been configured as shown below.

Selecting the [File] menu (or the [CLIP STUDIO PAINT] menu in the macOS/iPad version) → [Preferences] → 
[Ruler/Unit] allows you to change the unit of measurements such as the paper and brush size to [px] or [mm]. Set 
[Unit of length] in [Unit] to the unit you want to use and click [OK].

In EX, you can create a manga work containing multiple pages. To do this, turn on [Multiple pages] and specify the 
number of pages.
For details, see "Before Drawing a Work in CLIP STUDIO PAINT" →  "Page Management [EX]" .
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2 Click [OK] to create the canvas.

Tips: What Is the Expression Color?
"Expression color" is a term for the type of color handled in a file or layer. You can set one of three expression colors for each layer in : Mono-
chrome, Gray or Color. The images below are an example of layers where each expression color (Color, Gray, Monochrome with black and 
white as the drawing colors) is applied to a pattern drawn with the same [Decoration] tool settings. 

The expression color can be set in the [New Raster Layer] dialog box or the [Layer Property] palette.

If a [Basic expression color] is set in the [New] dialog box, that expression color is automatically set for each new layer created on the canvas.
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Monochrome
This expression color handles one or two colors as well as transparency. You can create full duotone data (images with two color values). The 
drawing colors (the colors handled on the layer) can be set as black and transparent, white and transparent or black and white.

It is recommended to set the expression color as "Monochrome" from the beginning when creating a manga draft for monochrome printing.

When Monochrome is set as the expression color of a layer, the image is drawn as duotone data even when using drawing tools with anti-alias-
ing or posterization. When drawing with colors other than black and white, the darker color is displayed as [Black] and the lighter color is dis-
played as [White].

To use posterization for monochrome printing, draw on a layer with Gray or Color set as the expression color and then enable [Tone] on the 
[Layer Property] palette. Converting to tones creates a similarly posterized effect.

Gray
This expression color handles 256 achromatic colors.

Black and transparent, white and transparent or black and white can be used, each with 256 combinations of the two colors.

Use this for posterized black and white images or monochrome images to be displayed by media such as websites.

Color
This expression color handles around 16.77 million colors.

It includes almost every color that can be discerned by the human eye. Use this for chromatic images such as color illustrations and color 
manga.

Monochrome 

(Black/White/Transparent)

Monochrome 

(Black/Transparent)

Monochrome 

(White/Transparent)

Gray 

(Black/White/Transparent)

Gray 

(Black/Transparent)

Gray 

(White/Transparent)
CLIP STUDIO PAINT STARTUP GUIDE 134



Try Drawing a Manga in CLIP STUDIO PAINT Monochrome Manga Guide [PRO/EX] > Creating a New Manga and Storyboard
Layer Icons
The following layer icons are displayed to indicate monochrome, gray and color layers.

The squares at the bottom of the Monochrome and Gray icons indicate the drawing colors being used.

However, colors set for [Basic expression color] are not shown as icons for the layers on the [Layer] palette.

Configuring the Settings of the Storyboard Layer
Change the settings on the raster layer for initial settings to configure the ideal settings for drawing the storyboard and draft.

Changing the Layer Name
On the [Layer] palette, double click the layer name of "Layer 1" and change the layer name to "Storyboard".

Setting the Expression Color and Layer Color
Only black and white can be used for drawing on layers where the initial expression color setting is [Monochrome]. Change the expression 
color of the layer to create a rough drawing with strokes in different tones as with a pencil. Change the [Layer color] so that the lines drawn for 
the storyboard can be easily distinguished from the lines that will be drawn later.

1 On the [Layer Property] palette, select [Gray] for [Expression color].

If this palette is not displayed, you can display it using the [Window] menu. For details on how to display the 
[Layer] palette on the iPad, see  "Tips: When displaying the layer palette on the iPad" .

Monochrome Gray Color

The layer icon is displayed

when the expression color is changed.
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2 Click [Layer color] on the [Layer Property] palette.
[Layer color] is a function in which all content drawn on a layer is displayed in the specified color. When this is turned on, all content 
drawn in gray is displayed in an alternative color (in this case blue) so that this content can be easily distinguished from other content.

Tips: Editing the Layer Color
Turning on [Layer color] on the [Layer Property] palette allows you to specify an alternative color. Clicking the color indicator configures the 
selected drawing color. Clicking the [▼] icon, will bring up the [Color settings] dialog box to set color. Configuring a color changes the display 
color of the layer to the configured color. Using different colors for different types of drawn content makes it easy to distinguish them.

Setting the Draft Layer
Setting a layer as a [Draft Layer] allows you to remove the layer from the references for processes such as filling while still showing the layer. 
It also removes the layer from the targets for processes such as printing and exporting.

On the [Layer] palette, select the "Storyboard" layer and then click [Set as Draft Layer].

The layer color

icon is displayed.

The layer color is displayed.

Click to change to

the current drawing color

Click to display a dialog

for setting the color

This icon is displayed when

a layer is set as a draft layer.
CLIP STUDIO PAINT STARTUP GUIDE 136



Try Drawing a Manga in CLIP STUDIO PAINT Monochrome Manga Guide [PRO/EX] > Creating a New Manga and Storyboard
Drawing the Storyboard
Use the [Pencil] tool and [Eraser] tool to draw the storyboard based on the "Bleed border", "Cropped border" and "Default border" displayed on 
the canvas.

Tips: iPad Specific Operations
On the iPad, some operations may differ. For operations specific to the iPad, please refer to the next point.

 About Screen Configuration  "When using an iPad" → "Screen Configuration" 

 Using convenient modifier keys:  "List of Frequently Used Shortcuts" → "Edge Keyboard (iPad)" 

 Using the drawing tool:  "Rough Draft" → "Using the drawing tools (iPad)" 

 When displaying the layer palette on the iPad:  "What is a Layer?" → "Tips: When displaying the layer palette on the iPad" 

Tips: Area Visible after Printing and Binding
The green border in the image below is called the "Bleed width". The inner line is called the "Cropped border". The area inside this border will 
be visible after printing. The outer line is called the "Bleed border". The area between this and the cropped border may be visible if the page is 
off center during printing or trimming.

The border further inward from the "Cropped border" is called the "Default border". This is a guideline for the position of the frames.

The book will be trimmed along the "Cropped border", but the position may be inaccurate by several millimeters. The bleed width is primarily 
there for this purpose. If drawing a picture that will extend to the edge of the page, draw as far as the "Bleed width".

For details on the basic drawing methods for the storyboard and draft, see "Try Drawing an Illustration in CLIP 
STUDIO PAINT: Basic Guide" →  "Rough Draft" .

Cropped border

Bleed border

Default border
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Make sure that all content you do not want to lose is drawn inside the "Cropped border". Note that some of the printed content may still disap-
pear depending on binding specifications such as the binding point. Make sure that all important content, such as dialog and the characters' 
expressions, is drawn inside the default border.

Finishing the Storyboard
Draw and erase gradually until the storyboard is finished. The storyboard is now complete.

You can show or hide the crop marks and default border by selecting the [View] menu → [Crop mark/Default bor-
der].

Draw features such as characters' expressions

and dialog inside the default border.

Cropped 
border

Default 
border

Draw up to the

bleed width (green area).

The content drawn up to the cropped border is shown 

above to indicate the content that will be available after 

printing and binding.
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 Creating Balloons and Dialog
Balloons are an essential element for expressing dialog in manga. You can create these using the [Text] tool.

Creating a Balloon
The [Text] tool allows you to create balloons in a wide variety of shapes.

Ellipse Balloons
Draw a balloon using the [Ellipse balloon] sub tool.

1 Select [Window] menu → [Color Set] to show the [Color Set] palette.

2 Select black from the [Color Set] palette. Check that the main color on the [Tool] palette is
now black and click to select the main color.

3 Select [Balloon] tool → [Ellipse balloon] from the [Tool] palette.

4 In the [Tool Property] palette, change the [Brush Size] to set the line width of the balloon.
Set anti-aliasing to [None].

Check that the

main color is black.

None
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5 Click and drag on the canvas to draw the outline of the balloon.

6 Drawing of the basic shape of the balloon is now complete. A balloon layer is created on
the [Layer] palette when the balloon is created.

Drag to confirm
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Rectangle Balloons
You can change the settings of the [Ellipse balloon] tool to create a rectangle balloon.

1 Select [Balloon] tool → [Ellipse balloon] from the [Tool] palette.

2 Change [Figure] to [Rectangle] in the [Tool Property] palette. Change the [Brush Size] to
the desired value.

3 Click and drag in the desired location to draw a rectangle balloon.
You can draw two overlapping balloons to create two rectangles joined together as shown below.

To draw a freehand balloon or a balloon whose shape cannot be created easily with the [Text] tool, create a new 
[Raster layer] and draw it directly using tools such as the [Pen] tool.

Change the shape of the balloon
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Adjusting the Shape of the Balloon
Once the balloon layer is created, you can use the [Object] tool to adjust the shape and size of the balloon.

1 Select the [Operation] tool → [Object] from the [Tool] palette.

2 Adjust the shape of the balloon.
You can enlarge or shrink the balloon by selecting the balloon and dragging one of the guide points that is displayed.

Dragging a handle while holding down the [Shift] key allows you to maintain the current aspect ratio while resiz-
ing.

Select a handle

and drag
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Tips: Outlines of Balloons
You can use the [Tool Property] palette to edit the advanced settings of the balloon outline such as the line color, ground color, brush size and 
brush shape.
CLIP STUDIO PAINT STARTUP GUIDE 143



Try Drawing a Manga in CLIP STUDIO PAINT Monochrome Manga Guide [PRO/EX] > Creating Balloons and Dialog
Attaching a Tail to a Balloon
Attach a tail to the balloon.

1 From the [Tool] palette, select the [Balloon] tool → [Balloon tail]. In this case, the [Tool 
Property] palette has been configured as shown below.

2 Click inside the balloon and drag outward to attach a tail to the balloon.

You can adjust the position of the tail by dragging the control point using the [Object] tool.

Drag

Drag to moveControl point
CLIP STUDIO PAINT STARTUP GUIDE 144



Try Drawing a Manga in CLIP STUDIO PAINT Monochrome Manga Guide [PRO/EX] > Creating Balloons and Dialog
Entering Dialog
When the balloon is completed, enter text.

1 From the [Tool] palette, select the [Text] tool → [Text] then use the [Tool property] palette 
to make settings as shown below.

2 Click inside the balloon on the canvas to enter text. Click outside the text area to commit
the content.

To enter other text, click another area with the [Text] tool after entering this text. Click inside an existing balloon to add more text to the 
same balloon layer or click in an area with no balloon to create a new text layer.

Vertical

Font size

Click outside text

area to confirm
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Tips: Adjusting the Text
You can correct text that you have entered by using the [Text] tool or the [Object] tool. To correct text that you have entered, select the text on 
the canvas with the [Text] tool.

To change the size or position of the text, drag the guide points of the text on the canvas while the [Text] tool or [Object] tool is selected. You 
can change the font or the text size by using the [Tool Property] palette.

Select the area to be corrected

Move text

Scale text size

up/down
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Adding a Reading for Text
You can add a reading for input text using the [Text] tool.

1 Select the text which you want to add the reading using the [Text] tool.

2 Click the [Sub Tool Detail] button on the [Tool Property] palette to open the [Sub Tool
Detail] palette.
Click [Reading] on the [Sub Tool Detail] palette and click [Reading setting]. A popup is displayed. Enter the text for the reading in [Read-
ing string].

Click the reading setting

to display a popup.

Input the [Reading string].
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3 The reading is added to the text.

4 Repeat the same steps to configure the settings of the balloon.
A sea urchin flash will be created for the final dialog in a later process. Click an area with no balloon and enter only the text for this dialog. 
A new text layer is created as you clicked outside of the balloons.
CLIP STUDIO PAINT STARTUP GUIDE 148



Try Drawing a Manga in CLIP STUDIO PAINT Monochrome Manga Guide [PRO/EX] > Creating Balloons and Dialog
5 On the [Layer] palette, select the text layer you created and click [Combine to layer below].
The two separate text layers are combined as one layer for easier management.

Tips: Correcting a Reading
To correct a reading you have entered, select the text of the reading on the canvas and correct it in the [Reading setting] of the [Sub Tool Detail] 
palette. To delete a reading, click the [Delete] button in the popup.

Combinations of multiple text (balloon) layers are not rasterized, and are treated as text (balloon) layers even after 
being combined.

Merge with layer below

Delete the reading

Correct the reading
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 Draft
Adjust the draft lines of the characters and background in each frame based on the storyboard.

Preparing the Layers
Create a raster layer and set it as a [Draft layer].

1 Select the [Layer] menu → [New Layer] → [Raster layer].
In the [New Raster Layer] dialog box, select [Gray] as the [Expression color] and set "Draft" as the layer name.

2 Select the "Draft" layer and click [Set as Draft Layer] on the [Layer] palette.

3 On the [Layer] palette, change the stacking order of the layers by dragging the "Draft" layer
so that it is immediately above the "Storyboard" layer.

To create a layer with a different expression color (or other setting) from the initial settings, create it from the 
[Layer] menu so that you can change the settings when creating the layer.
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Drawing a Draft
Use the [Pencil] tool and [Eraser] tool to draw a draft on the "Draft" layer.

Your draft is now complete.

For details on how to draw a draft, see "Try Drawing an Illustration in CLIP STUDIO PAINT: Basic Guide" →  
"Rough Draft" .
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 Adding the Border Lines
When drawing border lines, creating a [Frame Border folder] allows you to process or correct individual frame borders
together.

Creating a Frame

1 Select [Layer] menu → [New layer] → [Frame Border folder].

2 In the [New frame folder] dialog box, set the [Line width], enter "Border" as the name and
click [OK].
"15.00px" has been set as the line width in this case, but this can be changed according to the size of the draft or your preference.

A [Frame Border folder] is created in the [Layer] palette.
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3 Drag the [Frame Border folder] to move it below the balloon layer.

When the [Frame Border folder] is selected on the [Layer] palette, you can check the frame areas on the canvas.

The white area in the figure below is the area of the image that is displayed in the frames. When you draw on the layers in the [Frame Bor-
der folder], the blue area is masked, and content drawn outside the border lines is not displayed.

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move 
it. For details, see  "Drawing the Fine Details"  →  "Drawing the Eyes (Combine Layers)"  →  "Drawing the White of 
Eye"  →  "Tips: When unable to move layers on the iPad." .
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Dividing a Frame Border
Split the [Frame Border folder] you have created according to the border lines on the storyboard.

1 Select the [Frame Border] tool → [Cut frame border] → [Divide frame border].

2 On the [Tool Property] palette, set the division gaps of the frame borders as shown below.

3 Drag along the border lines drawn in the storyboard to split the frame borders.
Split the border lines in the order indicated by the numbers below.

The gaps of the border lines can be changed as desired using the [Tool Property] palette. In this case, [Horizontal 
space] is set to "60" and [Vertical space] is set to "130".

To make parallel or perpendicular divisions, hold down the [Shift] key while dragging.
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Adjusting the Shape of the Frame Borders
Once the frame borders are split, you can use the [Object] tool to adjust the shape and size of the border lines in the same way as with the bal-
loons.

Bleed Settings
Clicking one of the triangular handles allows you to extend the border line to the edge of the canvas, the crop marks and/or the adjacent frame 
border(s) and make the frame a bleed frame.

Extend the first frame border upward and to the right and extend the fourth frame border downward.

Deleting Unneeded Frames
Delete frames for which border lines do not need to be drawn.

1 Using the [Object] tool, click to select the frame border of the frame that is not needed.
@

 The frame shape can be edited in greater detail by configuring the settings on the [Tool Property] palette.

 Multiple frames can be selected by holding down the [Shift] key while clicking the frame border lines.

Click

The frame border extends

as far as the edge of the canvas.

Click the area around the

frame border to select
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2 Select [Edit] menu → [Clear].

The frame border is erased.

The frames in this example will be numbered as follows for the rest of this guide.
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 Inking the Characters
Ink the characters based on the draft to complete the main lines of the characters.

1 On the [Layer] palette, select the "Draft" layer and change [Opacity] to 50% to make the 
inking easier to see.

2 Click [New Raster Layer] on the [Layer] palette. Double click the layer name of the layer
you have created and enter "Characters 1".
Change the stacking order of the layers so that the "Characters 1" layer is immediately above the "Border" layer, as "Characters 1" contains 
characters that will run over the frame border.

3 Set black as the main color on the [Tool] palette.
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4 On the [Tool] palette, select the [Pen] tool → [Pen] → [G-pen] and draw the main lines of the
character with black as the drawing color.

Draw the character, using the [Pen] tool to draw and the [Eraser] tool to make corrections.

5 Draw the character in Frame 1 and the bust-up character in Frame 3 on the "Characters 1"
layer.
If the balloons or border lines make it difficult to draw, hide them temporarily on the [Layer] palette.

Drawing of the characters in Frames 1 and 3 is now complete.

[Anti-aliasing] is not applied to lines drawn in processes such as inking when the [Basic expression color] is 
Monochrome. This may cause the lines to look rough on the screen of your computer.

Check that the

main color is black.
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6 Next, draw the main lines for the character in Frame 4. With the [Frame Border folder]
selected, click [New Raster Layer] on the [Layer] palette. Change the layer name to "Char-
acters 2".

The white area in the figure below is the area of the image that is displayed in the frames. Content drawn outside the border lines on the 
layers in the [Frame Border folder] is not displayed.

Not displayed outside

the frame border
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7 Repeat this process to draw the front character in Frame 1 on the "Characters 2" layer.

8 The main lines of the characters are complete.

For details on inking, see "Try Drawing an Illustration in CLIP STUDIO PAINT: Basic Guide" →  "Inking" .
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 Inking the Background
Ink the background to complete the main lines of the background. Draw the background of Frame 1 using [Perspective
ruler].

1 Select [Layer] menu → [Ruler - Frame] → [Create Perspective Ruler].
Configure the perspective ruler settings in the [Create Perspective Ruler] dialog box. [1 point perspective] is selected for this example.

2 The perspective ruler is created.

3 On the [Layer] palette, change the stacking order of the layers by dragging the "Perspec-
tive ruler 1" layer into the "Border" folder.

Drag and drop to the area with the

short red line to place in the folder. 
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4 Adjust the vanishing point position of the perspective ruler you have created. Select the
[Operation] tool → [Object].

5 As the eye level is tilted in the background of Frame 1, tilt the eye level of the perspective
ruler based on the draft.
Select the handle for moving the eye level on the perspective ruler you have created and move the eye level so that it matches the horizon 
line drawn in the draft of Frame 1.

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move 
it. For details, see  "Drawing the Fine Details"  →  "Drawing the Eyes (Combine Layers)"  →  "Drawing the White of 
Eye"  →  "Tips: When unable to move layers on the iPad." .

Drag
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Drag the handle for changing the direction of the eye level so that it matches the angle of the horizon line.
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6 Drag the guide line to adjust the vanishing point position according to the draft.
Adjust the vanishing point so that it is near where the character is standing.

7 Check that the [Snap to Special Ruler] icon on the upper command bar is turned on.
This allows you to snap the line to the perspective ruler.

8 Draw the background using the same [G-pen] as when drawing the characters. Check that
black is set as the main color on the [Tool] palette.

[Snap to Special Ruler] is usually turned on automatically when a perspective ruler is created. Turn it off if you do 
not want to snap to the ruler.

Handle for moving guide line Handle for moving vanishing point

Vanishing Point

Check that the

main color is black.
CLIP STUDIO PAINT STARTUP GUIDE 164



Try Drawing a Manga in CLIP STUDIO PAINT Monochrome Manga Guide [PRO/EX] > Inking the Background
9 Draw the background while snapped to the ruler.

10When you have finished drawing lines according to the perspective ruler, turn off [Snap to
Special Ruler] on the command bar and add the character at the back and the small items
such as the manga drafts scattered around the room.

Turn off [Snap to Special Ruler]
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The main lines of the background are complete.

Tips: Hiding the Perspective Ruler
The [Perspective ruler] is still shown after you finish drawing the background. To hide it, select the [Layer] palette → [Set showing area of 
ruler] and uncheck the check box.

Uncheck to hide

the ruler
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Inking the Effect Lines
Draw effect lines such as saturated lines and stream lines.

Saturated line
Draw saturated lines in the background of Frame 1. The [Saturated line] tool will be used in this frame.

1 Select the [Figure] tool → [Saturated line] → [Dark saturated line(curve)].

2 Click to the right of the character in Frame 1 and specify the area using a curved line.
Double click to commit the curved line area you have created using [Dark saturated line(curve)].

The saturated lines are created.

Double click to confirm

Click

Click
Click
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3 Saturated lines created with the [Saturated line] tool can be adjusted later using the
[Object] tool.
Select the [Object] tool on the [Tool] palette and drag the control points to adjust the area of the saturated lines. The density of the satu-
rated lines is also too high by initial settings. While the [Object] tool is selected, adjust values such as the [Gap of line] on the [Tool Prop-
erty] palette, checking the effect on the canvas.

4 The saturated lines in Frame 1 are now complete.

Click the "+" mark on the [Tool Property] palette or [Layer Property] palette to display related settings.

Control point

of guide line

Handle of guide line

Click to

expand item
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Stream Lines
Draw stream lines in the background of Frame 4. The [Special ruler] will be used in this frame.

1 Select the [Frame Border folder] on the [Layer] palette and click [New Raster Layer].
Change the layer name of the created layer to "Stream line".

2 Select the [Ruler] tool → [Special ruler] and select [Parallel line] from [Special ruler] on the
[Tool Property] palette.
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3 Click on the canvas to create the [Parallel line ruler].

4 Draw with the [Pen] tool.
Freehand lines will also become parallel lines according to the guide lines of the [Special ruler]. Vary the pen pressure so that the lines trail 
off to create stream lines (speed lines).

Tips: Moving the [Parallel line] in Special Ruler and Changing the Angle
You can change the [Parallel line] type of [Special ruler] to your desired angle and position. Move the [Parallel line] in special ruler by drag-
ging on the lines of the ruler using the [Object] tool. Dragging the [Center of rotation] on the ruler changes the angle.

Guide line

It is possible to

draw along guide lines.

Drag to move

the [Parallel lines].

Rotate using

[Center of rotation].

Center of rotation (+)
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Sea Urchin Balloons
Create a sea urchin balloon.

1 Click the [Balloon] tool and select [Flash] → [Dense flash] on the [Sub tool] palette.

2 Select the [Frame Border folder] on the [Layer] palette.

3 Drag on the image to draw a sea urchin balloon based on the draft.

4 Select the [Object] tool and configure the following settings on the [Tool Property] palette.

Drag
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5 Correct the area where the balloon is covering the character.
On the [Layer] palette, select the "Saturated line" layer and click [Create layer mask].

It is not possible to draw with the [Pen] tool and [Eraser] tool on layers created using the [Saturated line] tool. Corrections therefore need 
to be made using the [Layer Mask] function.

Select the [Eraser] tool → [Hard] and trace along the area where the balloon is covering the character to mask the area.

The [Eraser] tool draws on the layer mask, meaning that while the balloon itself is not erased, it is hidden by the mask.

6 The sea urchin balloon is now complete.

Using the [Layer Mask] allows you to hide part of the content drawn on the layer.
For details on layer masks, see "CLIP STUDIO PAINT User Guide" → "Layer Menu" → "Layer Mask".

The area traced by the

[Eraser] tool is masked.
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 Fill in monochrome
Create a new layer and fill in monochrome using the [Fill] tool.

Creating a Layer for Filling in Monochrome
Create a layer for filling in monochrome and then fill the inked character and background in black monochrome.

1 The draft and storyboard will not be used from this point onward, so hide the "Draft" layer 
and "Storyboard" layer on the [Layer] palette.

Selecting the [Saturated line] and [Stream line] sub tools of the [Figure] tool or the [Flash] sub tool of the [Bal-
loon] tool allows you to draw various kinds of saturated lines and stream lines easily by configuring the settings 
on the [Tool Property] palette. The [Ruler] tool also allows you to use features such as [Special ruler], which 
allows you to draw parallel lines, concentric circles or focus lines, and the [Perspective ruler], which enables 
accurate drawing of backgrounds, in addition to drawing shapes.

Click

[Show/hide layer].
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2  Click [New Raster Layer] on the [Layer] palette. Change the layer name of the created
layer to "Fill".

3 Select the [Pen] tool and draw the border lines of the area for filling in monochrome.

4 Select the [Fill] tool and then select the [Sub tool] palette → [Fill] → [Refer other layers].
Configure the properties on the [Tool Property] palette as shown below.

The areas drawn with the

[Pen] tool are shown in red.
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5 Click the areas of the content drawn on the "Characters 2" layer to be filled in mono-
chrome and fill the areas.

6 Repeat this process to fill Frames 1 and 3 in monochrome. Select the "Characters 1" layer
on the [Layer] palette and click [New Raster Layer] to create a new layer.
Change the layer name of the created layer to "Fill 2".

7 Follow the same process to fill in monochrome using the [Pen] tool and [Fill] tool.

Click
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8 Filling in monochrome is complete.

Filling in White (Before Finishing)
The border lines overlap with the characters in some areas. Fill these areas in white so that the intersecting parts of the border lines are hidden 
behind the characters.

1 Click [New Raster Layer] on the [Layer] palette.

2 Change the layer name of the created layer to "White". Change the stacking order of the
layers so that the "White" layer is below the "Characters 1" layer.

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move 
it. For details, see  "Drawing the Fine Details"  →  "Drawing the Eyes (Combine Layers)"  →  "Drawing the White of 
Eye"  →  "Tips: When unable to move layers on the iPad." .
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3 Hide the [Paper] layer on the [Layer] palette so that the white filled areas can be seen eas-
ily.

4 Check that the sub color on the [Tool] palette is white and click the sub color.
If white is not set as the [Sub color], select white on a palette such as the [Color Set] palette.

5 Use the [Pen] tool and [Fill] tool in the same way as when filling in monochrome to fill the
areas of the character intersected by the border lines in white.

6 When you have finished filling in white, display the "Paper" layer again on the [Layer] pal-
ette.

Click

[Show/hide layer]
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 Finishing (Tones and Gradients)
In manga drafts for monochrome printing, tones (fine black dots) are used to create gray half tones. CLIP STUDIO
PAINT has dedicated layers for tones and gradients. Use these to recreate elements such as shadows and the colors of
the characters' clothing.

Tips: What Are Filling in Monochrome, Tone and Gradient Layers?
CLIP STUDIO PAINT has the following dedicated layers:

 [Fill] Layer: A layer created when filling in a specified color.

 [Tone] Layer: A layer created when pasting a specified tone. This is created by applying toning to a layer filled in monochrome.

 [Gradation] Layer: A layer created when drawing a gradient.

Pasting a Tone Layer
Create a selection and paste a tone layer.

1 On the [Layer] palette, create a [Layer Folder] to manage the tone layers together.
Click [New Layer Folder] on the [Layer] palette to create a layer folder. Change the layer folder name to "Finish".
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2 Select the [Auto select] tool and then select the [Sub tool] palette → [Auto select] → [Refer
to all layers]. Configure the settings on the [Tool Property] palette as shown below.

3 Click the area in which to paste the tone and create a selection.

4 Click [New Tone] in the [Selection Launcher].

Click
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5 In the [Simple tone settings] dialog box, set the [Change screen frequency] and [Density]
as shown below and click [OK].

6 The tone is pasted. A toned [Fill in Monochrome] layer is created on the [Layer] palette
when the tone is pasted.

The area is automatically deselected after creating the tone if the tone is created in the [Selection Launcher]. In 
other cases, deselect the area by clicking [Deselect] in the [Selection Launcher] or selecting the [Selection] menu 
→ [Deselect].
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7 To paste the same tone to other areas, select the [Fill in Monochrome] layer you have cre-
ated in the [Layer] palette and add it to the other areas by using the [Fill] tool and [Pen]
tool.

When selecting a [Fill in Monochrome] layer on the [Layer] palette, click the layer name or the layer mask thumbnail, not the thumbnail of 
the layer.
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8 Repeat steps 2 to 7 to paste tones to other areas of the canvas, varying the density and
screen frequency to create different tones.
Changing the values for [Density] and [Screen frequency] in the [New Tone Settings] dialog box from step 5 allows you to create a new 
[Fill] layer different settings.

Tips: Mask Posterization
When toning is applied to layers such as [Fill in Monochrome] layers, [Mask expression] is set to [Yes] on the [Layer Property] palette. The 
results of operations such as erasing with the [Soft] sub tool of the [Eraser] tool differ depending on whether [Mask expression] is set to [Yes] 
or [No]. The content is also printed differently depending on whether [Print Settings] → [Expression color] is set to [Duotone (Toning)] or 
[Duotone (Threshold)].

[Mask expression]

[Yes]

[Mask expression]

[None]

When the tone is erased using the [Soft] sub tool

of the [Eraser] tool.
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Pasting a Gradient Tone
"Gradient tones" are tones with a dark to light gradient. In this example, gradient tones are used to add depth and express the direction of the 
light.

1 Select the [Auto select] tool on the [Tool] palette and select the [Sub tool] palette → [Refer 
to all layers].

2 Click the area in which to paste the gradient tone and create a selection.
To apply a continuous gradient to multiple areas, hold down the [Shift] key and select additional areas to select the areas together.

Click
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3 Select the [Gradient] tool on the [Tool] palette and select [Gradient] → [Manga gradient] on
the [Sub tool] palette.

4 Drag in the direction in which to apply the gradient.

5 Click the [Selection] menu → [Deselect] to deselect the selected area.

6 Adjust the direction and position of the gradient by selecting the [Object] tool on the [Tool]
palette and dragging the operation handle on the canvas.

Drag

Drag

Drag
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Follow the same process for the other areas, creating a selection in the area in which to apply the gradient tones and then pasting the gradi-
ent.

Tips: Tones Other than Dots
Various kinds of tones are available in CLIP STUDIO PAINT in addition to dots and gradients. Changing the [Type of tone] in the [Simple 
tone settings] allows you to use tones such as parallel lines and noise (sand pattern).

The gradient can be created in greater detail by configuring the settings on the [Tool Property] palette. For details 
on creating gradients, see " Tool Setting Guide" → "Tool and Sub Tool Categories" → "Gradient".
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Complex tone styles such as patterns, cross-hatching and backgrounds are also recorded on the [Material] palette.

Tones from the [Material] palette can be dragged and dropped to the canvas for use. Create a selection to add a tone to the selected area.

Drag and drop
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 Sound Effects Lettering
Draw lines for sound effect lettering using tools such as the [Pen] tool.

1 Click [New Layer Folder] on the [Layer] palette to create a layer folder. Change the name of 
the created layer folder to "Sound effect".
Change the stacking order of the layers so that the "Sound effect" folder is immediately below the "Balloon layer" folder.

2 Once the "Sound effect" folder has been created on the [Layer] palette, click [New Raster
Layer] to create a raster layer. Change the layer name of the created layer to "Whoosh".
Tidy up the [Layer] palette by clicking the [▼] marks next to the "Border" frame border folder and the "Finish" folder to close the folders.

3 Select the main color on the [Tool] palette.
Check that the main color is black. If a color other than black is selected, select black using a palette such as the [Color Set] palette.

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move 
it. For details, see  "Drawing the Fine Details"  →  "Drawing the Eyes (Combine Layers)"  →  "Drawing the White of 
Eye"  →  "Tips: When unable to move layers on the iPad." .

Click to close

the folder
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4 Set a large brush size for the [Pen] tool and write "Whoosh" as a sound effect lettering.

5 Click [New Raster Layer] on the [Layer] palette again and change the layer name to
"Bang".

6 Write "Bang" as a sound effect lettering.
After drawing the outlines of the text in black with the [Pen] tool, change the drawing color to white and fill the outlines using the [Refer 
only to editing layer] sub tool of the [Fill] tool.

Adding Edges to Sound Effects Lettering
Add edges around the sound effect lettering.

1 On the [Layer] palette, select the "Whoosh" layer.

2 Click [Border effect] on the [Layer Property] palette and click [Edges] in [Border effect].
Set the [Thickness of edges] to "13".
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3 Tidy up the [Layer] palette by clicking the [▼] mark next to the "Sound effect" folder to
close the folder.

Making Corrections
Make corrections such as adding white edges to areas where the line borders cannot be seen easily.

1 On the [Layer] palette, create a new raster layer above the "Fill 2" layer and set "White 2" 
as the layer name.

*Green is used to emphasize the white edge in this image.

Click to close

the folder
CLIP STUDIO PAINT STARTUP GUIDE 189



Try Drawing a Manga in CLIP STUDIO PAINT Monochrome Manga Guide [PRO/EX] > Sound Effects Lettering
2 Select the sub color on the [Tool] palette.
If the sub color is not white, select white on a palette such as the [Color Set] palette.

3 Draw in white using tools such as the [Pen] tool. Draw in white around the character too.

To select the content drawn on a layer, hold down the [Ctrl] key and click the thumbnail of the layer to select the 
drawn area.

*Green is used to emphasize the white highlight in this image.
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4 All of the frames are now complete.
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Tips: About White Outlines
White outlines are used to add a white edge around items such as characters. Adding a white outline makes the character, etc. stand out so that 
it is easier to see.

White outlines can be added either by drawing with the [Pen] tool or by outlining a selection.

To create a white outline from a selection, create the area to be outlined in white using the [Selection] tool. Select the [Edit] menu → [Outline 
Selection] and then select [Draw outside] in the displayed [Outline Selection] dialog box to draw a white outline.

Select [Draw outside].
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 Saving the File
CLIP STUDIO PAINT saves files in CLIP STUDIO FORMAT (extension: .clip).

1 Select the [File] menu → [Save as].

Save files in CLIP STUDIO FORMAT (extension: .clip) from the [Save as] dialog box.

To open a saved file, select the [File] menu →[Open file].
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Tips: Formats for Saving Files

CLIP STUDIO FORMAT (extension: clip).
The data of the currently open canvas is saved, with all layer information kept. Images created in CLIP STUDIO PAINT are saved in CLIP 
STUDIO FORMAT (extension: .clip).

Adobe Photoshop Document Format (Extension: psd) and Adobe Photoshop Big Document  
Format (Extension: psb)
The layers are not combined when saving using [Save as] or [Save Duplicate]. When saving using [Export], all layers are combined as a single 
layer. All layer information unique to CLIP STUDIO PAINT, such as [Toning] and [Special ruler], is discarded when saving.

BMP, JPEG, PNG, TIFF and Targa
All layers are combined when saving the data. All layer information is discarded.

Printing[Windows/macOS]
To print toned manga or illustrations in monochrome, select the [File] menu → [Print Settings] and then select [Duotone (Threshold)] for 
[Expression color] in the [Print Settings] dialog box.

Configure the same settings from the [File] menu → [Export (Single Layer)] even if exporting in a general image format such as BMP.

On iPad, the printing function cannot be used.
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Tips: Types of Duotone
When [Mask expression] → [Posterization] is set to [Yes] in [Tone] as an effect on the [Layer Property] palette, the mask can be blurred with 
gray posterization, but this effect cannot be printed in duotone. When printing in duotone, the result differs depending on whether [Duotone 
(Threshold)] or [Duotone (Toning)] is selected as the [Expression color] in the [Print Settings] dialog box.

Duotone (Threshold)
Dark areas are printed in black and light areas are printed in white, with brightness 50% as the threshold.

Duotone (Toning)
Posterization of opaque areas is toned according to the [Screen frequency] on the canvas.

Original image

Mask expression posterization: Yes

When exported with

[Duotone (Threshold)]

When exported with

[Duotone (Toning)]
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Try Drawing a Manga in CLIP STUDIO PAINT  Color Manga  Guide [PRO/EX]

 Process for Creating a Color Manga Manuscript
Follow the steps below to draw a color manga manuscript.

Follow the examples in the manual for monochrome manga

to create color manga. Hide balloons, sound effects and layers made

as tones when preparing to color.

The areas inside frame borders can be colored in the same way 

as characters and backgrounds.

Similar operations can be performed for sound effects.

Color the main lines of the characters. Draw fine details

using tools such as the [Pen] tool. The tone of the colors in each

colored area can be adjusted by changing the layer combine mode.

Create a layer for each part and then color each layer

using the [Fill] tool and [Watercolor] tool.

The created layers are stored in the [Layer Folder].

Use tools such as the [Decoration] tool to color the images.

Attributes of effect lines for color manga, such as the color and number of

lines, can be changed by changing the values in the [Tool Property] palette.

Draw and Adjust Fine Details

Color the 4th Frame Border

Color the Characters

Color the Background

Prepare to Create a Color Manga
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 Preparations before Creating a Color Manga
Color the manuscript you made according to the monochrome manga guide to create a color manga.

Preparations
In your monochrome manga manuscript, [Monochrome] is set as the [Basic expression color] of the canvas. If you create a new layer and use it 
for coloring with the current setting, the layer will be displayed in monochrome. Change the [Basic expression color] of the canvas to [Color].

Changing the Canvas Properties
Select [Edit] menu → [Canvas Properties]. In the [Canvas Properties] dialog box, change [Basic expression color] to [Color] and click [OK].

Hiding Layers Made as Tone
The toned [Fill in Monochrome] layers you created according to the monochrome manga guide are in the "Finish" folder. Hide this folder, as 
you will not use these layers to create your color manga. On the [Layer] palette, select the "Finish" folder and click [Show/hide layer] to hide 
the "Finish" folder.

In this case, the images will be created with a resolution of [600dpi] as you are using your manuscript from the 
monochrome manga guide. A resolution of around [300dpi] to [350dpi] is usually recommended when creating a 
color manuscript.
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Hiding the [Balloon] Layer and "Sound Effect" Folder
Hide the [Balloon] layer and "Sound effect" folder too to make the coloring process easier. Display the [Balloon] layer after you have finished 
coloring and display the "Sound effect" folder when you are ready to color the sound effects (if applicable).
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 Coloring the Characters
In this section, you will color the characters in Frames 1 and 3. Create a separate layer to color each character and
background.

Tips: iPad Specific Operations
On the iPad, some operations may differ. For operations specific to the iPad, please refer to the next point.

 About Screen Configuration  "Starting" → "When using an iPad" 

 Using convenient modifier keys:  "List of Frequently Used Shortcuts" → "Edge Keyboard (iPad)" 

 Using the drawing tool:  "Rough Draft" → "Using the drawing tools (iPad)" 

 When displaying the layer palette on the iPad:  "What is a Layer?" → "Tips: When displaying the layer palette on the iPad" 

Coloring the Base
Add the base color of the character. In this section, you will color the skin of the character in Frame 1.

1 On the [Layer] palette, select the "White" layer and click [New Raster Layer] to create a 
new layer.
Change the layer name of the created layer to "Skin".

2 Select [Window] menu → [Color Wheel] to show the [Color Wheel] palette.
Use the [Color Wheel] palette to select colors that are not on the [Color Set] palette. In this example, peach color is selected. Use the circle 
on the outside (1) to select the hue and the square at the center (2) to adjust the brightness and the saturation (how vivid the color should 
be).
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3 Click the area to be colored to fill the area surrounded by the lines.

Tips: If Small Areas are Left Unfilled
If small areas are left unfilled, select the [Fill] tool from the [Tool] palette and select [Close and fill] from the [Sub tool] palette. Closing the 
unfilled areas allows you to fill only the areas between the closed lines.

For details on filling with color and the basic coloring methods, see "Try Drawing an Illustration in CLIP STUDIO 
PAINT: Basic Guide" →  "Basic Coloring" .
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Coloring the Shadows
Create a new layer and fill the shadows of the character. In this section, you will add shadows to the skin.

1 On the [Layer] palette, select the "Skin" layer. Click [New Raster Layer] to create a raster 
layer.

2 Turn on [Clip at Layer Below] on the [Layer] palette.

3 Draw the shadow areas on the skin using tools such as the [Watercolor] tool and the [Pen]
tool.

Turning on [Clip at Layer Below] allows you to reference the layer immediately below so that drawing on the 
selected layer is confined to this area. For details, see "Try Drawing an Illustration in CLIP STUDIO PAINT: 
Advanced Guide" →  "Touching Up a Work Using the Clipping Function" .

Click

A red vertical line is displayed

next to the thumbnail of the layer.

Shadow Color

Shadow Color

Skin Tone
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4 Coloring of the "Skin" layer is now complete.

Storing in a Layer Folder
A convenient way of working with multiple layers is to create a layer folder to store the layers. Store the two layers used to color the skin in the 
layer folder.

1 Click [New Layer Folder] on the [Layer] palette to create a layer folder.
The name can be changed by double clicking the layer folder name.

2 Select the layers used for coloring and drag and drop them into the layer folder.
The selected layers are stored in the layer folder.

Areas where runover has occurred, such as the hair, will be colored by placing another layer on top. For details, 
see →  "Coloring Other Parts" .

 To select multiple layers, click the layers while holding the [Ctrl] key down.

 To select a group of consecutive layers, click the layers while holding the [Shift] key down.

Drag to the

[Layer Folder]

Stored in the

[Layer Folder].
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Coloring Other Parts
Follow the same process to color other parts, such as the hair and clothing.

1 Create a new layer for each part and color each part.

2 If you create multiple layers for the same part, create a layer folder for that part and store
the layers there.
Coloring of the character is now complete.

To color an area in white, such as the whites of the eyes, select white from the color palette. Do not fill them with 
the transparent color.
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 Coloring the Background
As with the characters, you will color the background in Frames 1 and 3.

Changing the Saturated Lines
Edit the [Saturated line layer] you created according to the monochrome manga guide.

1 Click the [▼] mark next to the [Frame Border folder] on the [Layer] palette to close the 
folder.

2 Select the "Dark saturated line(curve)" layer and change the [Expression color] from
[Monochrome] to [Color] on the [Layer Property] palette.
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3 Select the [Object] sub tool from the [Operation] tool and configure the settings on the
[Tool Property] palette as shown below.
Select dark pink as the [Main color] on the [Color Wheel] palette. This color is also applied as the [Main color] on the [Tool Property] pal-
ette.

The above settings have been changed to express the saturated lines suitably for a color manga. To configure the 
same settings as in the monochrome manga guide, use the settings in "Draw a Manga CLIP STUDIO PAINT: Mono-
chrome Guide" →  "Inking the Background"  →  "Inking the Effect Lines" .
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4 Select the [Window] menu → [Sub Tool Detail] to display the [Sub Tool Detail] palette.

5 Select [Middle] for [Anti-aliasing] on the [Sub Tool Detail] palette.

Turning on [Anti-aliasing] allows you to express colors in different tones.

The [Sub Tool Detail] palette allows you to edit all settings relating to the tool, including those that are not dis-
played on the [Tool Property] palette.
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6 The saturated lines are now complete.

Changing the Stream Lines
Change the "Stream line" layer to color in the same way as with the saturated lines.

1 Select the "Stream line" layer and change the [Expression color] from [Monochrome] to 
[Color] on the [Layer Property] palette.

2 Select dark blue on the [Color Wheel] palette. Select [Edit] menu → [Change color of line to
drawing].

The color of the stream lines is changed to the color selected as the [Main color].
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Try Drawing a Manga in CLIP STUDIO PAINT Color Manga Guide [PRO/EX] > Coloring the Background
3 Turn on [Snap to Special Ruler] on the [Command Bar]. Draw along the special ruler to add
more stream lines.

4 The stream lines are now complete.
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Coloring with the Decoration Tool
Color the background of Frames 2 and 3 using the [Decoration] tool.

Preparing the Layers
Prepare the layers for drawing the background.

1 Click [Show/hide layer] next to the [Paper] layer on the [Layer] palette to hide the [Paper] 
layer.
When the [Paper] layer is hidden, the transparent parts are displayed in a checkered pattern.

2 On the [Layer] palette, select the "Draft" layer. Click [New Raster Layer] on the [Layer] pal-
ette to create a raster layer.
Change the layer name of the created layer to "Frames 2-3: Background".

Click
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Try Drawing a Manga in CLIP STUDIO PAINT Color Manga Guide [PRO/EX] > Coloring the Background
3 Select the [Selection] tool on the [Tool] palette and select [Polyline] on the [Sub tool] pal-
ette.

4 Use the [Polyline] tool to create a selection encompassing the area of Frames 2 and 3.

5 Select white as the sub color on the [Tool] palette and click [Fill] in the [Selection
Launcher].

The area encompassing Frames 2 and 3 is filled in white.

6 Click [New Raster Layer] on the [Layer] palette to create a raster layer.
Change the layer name of the created layer to "Frames 2-3: Background 2".

If the sub color is not white, select the sub color and then select white on the [Color Set] palette or [Color Wheel] 
palette.

Create selection
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7 Turn on [Clip at Layer Below] on the [Layer] palette.

Turn on [Clip at Layer Below] to confine the background drawing for Frame 2 to the area filled in white.

Drawing the Background of Frame 2
Use the [Decoration] tool to draw roses in the background of Frame 2.

1 Select the [Decoration] tool on the [Tool] palette and select [Flower] → [Rose] on the [Sub 
tool] palette.
Set [Brush Size] to "1000" and [Particle size] to "800" on the [Tool Property] palette.

For spray type brushes like the [Rose] brush, the [Brush Size] determines the area in which the pattern will be distributed and the [Particle 
size] determines the size of the pattern itself.

2 Select the main color on the [Color Wheel] palette and set pink as the drawing color. Check
that the sub color is white.
The [Rose] brush uses the main color for the lines of the rose pattern and the sub color for the filled area.

Main color

Sub color
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3 Draw roses at the character's feet in the background of Frame 2.
The [Rose] brush varies the direction of the rose randomly. Draw in the general position where you would like to place the roses. If the 
roses are not drawn in the desired direction, undo the action by selecting the [Edit] menu → [Undo] and then draw the roses again.

4 To correct an area, select the [Lasso] sub tool from the [Selection] tool and surround the
area to be corrected.

5 Select the [Edit] menu → [Transform] → [Scale up/Scale down/Rotate] and then scale the
pattern up slightly and adjust the position to fit the shape of the frame.
When you have finished adjusting the position and size, double click to commit the transformation.
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6 After you have finished scaling up/down, click the [Selection] menu → [Deselect] to dese-
lect the selected area.

Drawing the Background of Frame 3
Use the [Gauze cloud] sub tool of the [Decoration] tool to add texture to the background of Frame 3.

1 Select the [Gradient] tool on the [Tool] palette and select [Foreground to transparent] on 
the [Sub tool] palette.

2 Select purple on the [Color Wheel] palette and draw a downward gradient from the top of
the frame.

3 Select the [Decoration] tool on the [Tool] palette and select [Hatching and sand pattern] →
[Gauze cloud] on the [Sub tool] palette.
Set the brush size to "700" on the [Tool Property] palette.
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Try Drawing a Manga in CLIP STUDIO PAINT Color Manga Guide [PRO/EX] > Coloring the Background
4 Touch up the background of Frame 3 in dark blue.

Drawing Over the Background Color

1 Click [New Raster Layer] on the [Layer] palette to create a raster layer.
Change the layer name of the created layer to "Frame 3: Overpaint".

2 Turn on [Clip at Layer Below] on the [Layer] palette.

3 Click [New Raster Layer] on the [Layer] palette to create a raster layer.
Change the layer name of the created layer to "Frame 3: Overpaint".

4 Change the [Blending mode] of the "Frame 2: Overpaint" layer to [Multiply]. Turn on [Clip at
Layer Below].
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5 Use the [Soft] sub tool of the [Airbrush] tool to draw a pink gradient on the "Frame 2: Over-
paint" layer.
Set the [Brush Size] to around "1200".

6 Select the [Watercolor] tool from the [Tool] palette and select [Smooth watercolor] on the
[Sub tool] palette. Draw over the [Frame 3: Overpaint] layer in pale purple and white.
Set the [Brush Size] to 200-300.

7 Click [New Layer Folder] on the [Layer] palette. Change the name of the created folder to
"Background".
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8 Drag and drop the layers containing the background for Frames 2 and 3 into the "Back-
ground" folder and click the "▼" mark to close the folder.

9 Click [Show/hide layer] for the [Paper] layer to hide the [Paper] layer.

10The background of Frames 2 and 3 is now complete.

Click to close

the folder

Click
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 Coloring Inside the Border Lines (Frame Borders)
The "Border" frame border folder contains the layers on which the character and background of Frame 4 have been
drawn. Create a layer for coloring in the [Frame Border folder] and color the frame.

Coloring the Character in Frame 4

1 Select the "Characters 2" layer in the "Border" folder on the [Layer] palette and click [New 
Raster Layer].
Change the layer name of the created layer to "Skin 2".

2 Drag the "Skin 2" layer so that it is immediately below the "Characters 2" layer.

 The "Characters 2" layer contains the main lines. Moving the “Layer 1" layer immediately below the "Charac-
ters 2" layer ensures that the content added with the [Fill] tool and [Pen] tool does not cover the line drawing.

 With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and 
move it. For details, see  "Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide"  →  "Drawing the 
Fine Details"  →  "Drawing the Eyes (Combine Layers)"  →  "Tips: When unable to move layers on the iPad." .
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3 Color the "Skin 2" layer.
Click the [Fill] tool and then select [Refer other layers] from the [Sub tool] palette. Click the areas to be colored to fill them with the base 
color.

4 Draw over these areas by following the same steps as in  "Coloring the Characters" .

5 Color the other areas to finish coloring the character in Frame 4.

Click
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Coloring the Background

1 On the [Layer] palette, click [Show/hide layer] next to the "Dense flash", "Stream line" and 
"Dark saturated line(curve)" layers to hide these layers.

2 Click [New Raster Layer] on the [Layer] palette and change the stacking order so that the
created layer is at the bottom of the "Frame Border" folder.
Change the layer name of the created layer to "Frames 1-4: Background".

With the iPad, move any layers by hovering the mouse cursor over the grip on the right side of the layer and move 
it. For details, see  "Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide"  →  "Drawing the Fine Details"  
→  "Drawing the Eyes (Combine Layers)"  →  "Tips: When unable to move layers on the iPad." .

Click to hide

the layer
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3 Use the [Rectangle] sub tool of the [Selection] tool to create a selection encompassing the
area of Frame 4.

4 Select the [Gradient] tool on the [Tool] palette and select [Foreground to background] on
the [Sub tool] palette.

5 On the [Color Wheel] palette, set pale blue as the main color and beige as the sub color.
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6 Draw a gradient from left to right.
After you have finished drawing the gradient, click the [Selection] menu → [Deselect] to deselect the selected area.

7 Use the [Soft] sub tool of the [Airbrush] tool to add the ground color of the background in
Frame 1.

8 Click [New Raster Layer] on the [Layer] palette.
Change the layer name of the created layer to "Frames 1-4: Background 2".
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9 Use the [G-pen] sub tool of the [Pen] tool to draw the shadows of the characters and the
small items scattered in the background.

10Click [Show/hide layer] next to the "Dense flash", "Stream line" and "Dark saturated line
(curve)" layers to show these layers.
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 Coloring the Main Lines of the Characters and the 
Sound Effects

Color elements created according to the monochrome manga guide, such as the main lines of the characters and the
sound effect lettering, so that these elements blend well with the colored areas.

Coloring the Main Lines of the Characters

1 On the [Layer] palette, select the "Fill 2" layer and then select the [Layer] menu → [Merge 
with layer below].
The "Fill 2" layer and "Characters 1" layer are joined as the "Characters 1" layer.

2 Select the "Characters 1" layer and change the [Expression color] to [Color] on the [Layer
Property] palette.

3 Click [Lock Transparent Pixel] on the [Layer] palette.
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4 Use tools such as the [Watercolor] tool and the [Airbrush] tool to color the main lines and
areas filled in monochrome on the character.

5 On the [Layer] palette, select the "Characters 2" layer and change the stacking order so
that this layer is immediately below the "Fill" layer.

6 On the [Layer] palette, select the "Fill" layer in addition to the "Characters 2" layer and
then select the [Layer] menu → [Combine Selected Layer].
The "Fill" layer and "Characters 2" layer are joined as the "Characters 2" layer.

7 With the joined "Characters 2" layer selected, click [Lock Transparent Pixel]. Change the
[Expression color] to [Color] on the [Layer Property] palette.

Click to select

multiple layers
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8 Color the main lines and areas filled in monochrome on the "Characters 2" layer using tools
such as the [Watercolor] tool and the [Airbrush] tool.

9 The main lines of the character are now colored.
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Coloring the Sound Effect Lettering

Sound Effect Lettering in Frame 2
Color the "Whoosh" layer in Frame 2.

1 On the [Layer] palette, click [Show/hide layer] next to the "Sound effect" folder to show the 
"Sound effect" folder.

2 Click the [▼] mark next to the "Sound effect" folder to open the folder.

3 While the "Whoosh" layer is selected on the [Layer] palette, click [New Raster Layer].
A new raster layer is created above the "Whoosh" layer.

4 Turn on [Clip at Layer Below] on the [Layer] palette.
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5 Select the [Gradient] tool → [Foreground to background] sub tool.
On a palette such as the [Color Wheel] palette, set navy blue as the main color and reddish purple as the sub color.

6 Drag as shown below to draw a gradient from the foreground color to the background color.

7 On the [Layer] palette, change the [Blending mode] of the layer where the gradient was
drawn to [Screen] so that the white edges remain.

Drag
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Sound Effect Lettering in Frame 4
Color the "Bang" layer in Frame 4.

1 On the [Layer] palette, select the "Bang" layer and change the [Expression color] to [Color] 
on the [Layer Property] palette.

2 Select the [Selection] menu → [Select Color Gamut] and set [Error margin of color] to "10"
in the [Select Color Gamut] dialog box.

3 Click the white part of the "Bang" sound effect on the canvas and click [OK] in the [Select
Color Gamut] dialog box.
All of the white areas on the "Bang" layer are selected.

Click the white area

The selection is created
CLIP STUDIO PAINT STARTUP GUIDE 229



Try Drawing a Manga in CLIP STUDIO PAINT Color Manga Guide [PRO/EX] > Coloring the Main Lines of the Characters and the Sound Effects
4 Select a pale orange on the [Color Wheel] palette and click [Fill] in the [Selection
Launcher].

The areas surrounded by the selection are colored.

5 Draw over the area in reddish purple using the [Soft] sub tool of the [Airbrush] tool.

6 After you have finished filling with the gradient, click the [Selection] menu → [Deselect] to
deselect the selected area.

7 Add white edges to the sound effect lettering. Click [Border effect] on the [Layer] palette
and set [Thickness of edges] to "20".

Click
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8 Coloring of the main lines of the character and the sound effect lettering is now complete.

For details on [Lock Transparent Pixel], see "Try Drawing an Illustration in CLIP STUDIO PAINT: Basic Guide" →  
"Basic Coloring" .
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 Drawing and Adjusting the Fine Details
Create a new layer and draw the fine details, checking the overall balance.

Drawing the Fine Details

1 Select the "White 2" layer and change the [Expression color] to [Color] on the [Layer Prop-
erty] palette.

Changing the expression color in [Layer Property] allows you to add colors other than white.

2 Add white areas and the highlights of the hair and eyes using tools such as the [Water-
color] tool and the [Pen] tool.
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3 Draw the fine details, checking the overall balance.

Adjusting the Color
Use the blending modes to adjust the tone of the color manga.

1 While the "White 2" layer is selected on the [Layer] palette, click [New Raster Layer].
Change the layer name of the created layer to "Effect".

2 Change the [Blending mode] to [Soft light] on the [Layer] palette.
Changing the [Blending mode] between layers allows you to create various effects and adjust the tones of the colors.
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3 Add color to the "Effect" layer using tools such as the [Watercolor] tool and the [Airbrush]
tool.

4 Click [Show/hide layer] next to the [Balloon] layer on the [Layer] palette to show the [Bal-
loon] layer.

*Example of "Effect" layers combined by normal combining

Click
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5 Your color manga is now complete.
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 Saving the File
When your work is complete, save the file. To keep the layer structure you created in CLIP STUDIO PAINT, save in CLIP STUDIO FORMAT 
(extension: .clip).

1 Select the [File] menu → [Save as].

2 Save files in CLIP STUDIO FORMAT (extension: .clip) from the [Save as] dialog box.

To open a saved file, select the [File] menu →[Open file].
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tion in CLIP STUDIO 
PAINT
This section explains how to create a moving illustration using CLIP STUDIO PAINT.
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Make a Moving Illustration in CLIP STUDIO PAINT

 Process for Creating a Moving Illustration
Below are the steps you need to follow to create a moving illustration.

First, think about how you want your moving illustration 

to look. Create a new canvas and draw a draft for each cel.

Export
Export your completed moving illustration as a file such as 

an animated GIF or movie. Exported files can be posted on 

social media and other websites.

Inking and Coloring
Create a layer folder for each cel draft.

Ink and color the cels, adding a new layer for each process.

Editing the Timeline
Play your moving illustration.

Adjust the playback time and speed of your moving 

illustration on the [Timeline] palette.

Planning and Draft
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 Planning and Draft
First, think about how you want your moving illustration to look, then create a new canvas and draw your drafts.

Planning
Think about how you want your moving illustration to look.

In this example, we will create a moving illustration of a character jumping, using the four illustrations shown below.

4-frame moving illustration of a character 

jumping
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Creating a New Canvas
Start CLIP STUDIO PAINT and create a new canvas for a moving illustration.

1 First, create a new canvas.
Select the [File] menu → [New] to open the [New] dialog.

2 Configure the settings in the [New] dialog.
In PRO or EX, start by selecting [Illustration] for [Use of work].

(1) Set [Unit] to [px].

(2) Enter "595" for [Width], "842" for [Height] and [72] for [Resolution].

(3) Turn on [Create moving illustration] .

(4) Enter "4" for [Number of cels] and set [Frame rate] to [8fps].

 If you are using DEBUT or PRO, the maximum number you can set for [Number of cels] is 24. It is not possible 
to set a larger number.

 Some web services may have an image size or file size limit. We recommend checking this beforehand and 
setting [Width] and [Height] accordingly.

 The size of images to be posted online is usually specified in px (pixels).

 We recommend setting a resolution of 72dpi - 144dpi if you will post your moving illustration on a web service 
such as social media.
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Display the Timeline Palette
The [Timeline] palette is a window for setting the motion of your illustration. Select the [Window] menu → [Timeline] to display the [Time-
line] palette.

[Timeline] palette

[Timeline] palette
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Check the Screen
You are now ready to start creating your moving illustration. Check that the screen is set up as follows.

 Check that an animation folder is created on the [Layer] palette and the number of cels (layers) is the same as the number specified for 
[Number of cels] in the [New] dialog.

 Check that the cels in the animation folder are specified in the [Timeline] palette.

 The animation folder is a folder used to manage animation cels. Layers stored in the animation folder are han-
dled as cels to set the motion of the animation.

 Specify cels on the [Timeline] palette to make the images in your animation move.
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Tips: iPad Specific Operations
On the iPad, some operations may differ. For operations specific to the iPad, please refer to the next point.

 About Screen Configuration  "Starting" → "When using an iPad" 

 Using convenient modifier keys:  "List of Frequently Used Shortcuts" → "Edge Keyboard (iPad)" 

 Using the drawing tool:  "Rough Draft" → "Using the drawing tools (iPad)" 

 When displaying the layer palette on the iPad:  "What is a Layer?" → "Tips: When displaying the layer palette on the iPad" 
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Drawing a Draft
Draw a draft for each cel.

Draw the First Cel
Draw the draft for the first cel.

1 Select cel "1" on the [Layer] palette.

2 Draw the draft using the [Pencil] tool and [Eraser] tool.

Your draft is now complete.

For details on drawing drafts, see  "Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide" → "Rough 
Draft" .
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Draw the rest of the cels
Draw drafts in the same way for the rest of the cels.

1 Select the cel to be drawn on the [Layer] palette.
In this case, cel "2" is selected.

2 Click [Enable onion skin] on the [Timeline] palette.

The illustration drawn on cel "1" is displayed on the canvas. This is called an "onion skin".

 Only the selected cel from the animation folder is displayed. Other cels in the same folder are not displayed.

 For details on drawing drafts, see  "Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide"  →  
"Rough Draft" .

Onion skin is a function that displays the cels surrounding the selected cel to help you keep the cels consistent. 
See  "Tips: Onion skin"  for information on changing the display color and number of displayed cels in the onion 
skin.
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3 Refer to the onion skin as you draw the draft of the cel.

4 When you have finished the draft, select the [Move layer] tool and drag the canvas.
The second cel was initially drawn in the same position as the previous cel, but for this animation the character is moving forward, so 
select the layer for cel "2" and move it to the left.

CSPaint06_010.eps

Drag
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5 Draw drafts in the same way for the remaining cels.
Once you have drawn drafts for all of the cels, the draft process is complete.

6 Click [Enable onion skin] on the [Timeline] palette.
This hides the onion skin.

Cel "1"

Cel "2"

Cel "3"

Cel "4"
CLIP STUDIO PAINT STARTUP GUIDE 247



Make a Moving Illustration in CLIP STUDIO PAINT > Planning and Draft
Tips: Onion skin
Onion skin is a function for displaying the cels surrounding the selected cel to help you keep the cels consistent. You can show or hide the 
onion skin by clicking [Enable onion skin] on the [Timeline] palette. Displaying the onion skin allows you to refer to cels that have already 
been drawn when drawing the current cel.

You can set the display color and number of cels displayed for the onion skin by selecting the [Animation] menu → [Show animation cels] → 
[Onion skin settings] to display the [Onion skin settings] dialog box.
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Check the Motion
Check the motion of the draft cels using the [Edit timeline] tool.

1 Select the [Operation] tool→[Edit timeline] on the [Tool] palette.

2 Click on the canvas.
The canvas switches to the next cel. Keep clicking to move through the cels.

The display does not change after the last cel is reached. Select the first cel on the [Layer] palette to move through the cels again.

You can also move through the cels by pressing the [→] and [←] keys on your keyboard when using the [Edit 
timeline] tool.

Click The next cel is 

displayed.

The cel selection 

also changes.
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 Inking and Coloring
Ink and color your drafts. If a cel requires multiple layers, you can create a layer folder. The layer folder is handled as a
cel.

Creating a Layer Folder
You can create a layer folder to handle multiple layers as one cel.

1 Select cel "1" on the [Layer] palette.

2 Select the [Layer] menu→[Create folder and insert layer].
A layer folder with the same name as cel "1" is created and cel "1" is stored as a layer folder. The layer folder is handled as one cel from 
this point onward.

You can also select [Create folder and insert layer] from the menu displayed by right clicking the layer name on 
the [Layer] palette.

cel
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3 Create layer folders in the same way for the other cels.
You have now created layer folders as follows.

Inking
Ink each cel.

Draw the First Cel
Add a layer to cel "1" (layer folder) and start inking.

1 Select the "1" layer in cel "1", double click the layer name and enter "Draft".
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2 Select the "Draft" layer in cel "1" and click [New Raster Layer] on the [Layer] palette.
A layer is created.

3 Double click the layer name of the layer you have created and enter "Line drawing".

4 Select the "Draft" layer and change [Opacity] to 50%.
Lowering the opacity of the draft makes it easier to see the inking lines.
CLIP STUDIO PAINT STARTUP GUIDE 252



Make a Moving Illustration in CLIP STUDIO PAINT > Inking and Coloring
5 Select the "Line drawing" layer and start inking.

6 Click the [Show/Hide Layer] icon on the left of the "Draft" layer to turn it off.
This hides the "Draft" layer so that only the line drawing is shown.

 For details on inking, see  "Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide"  →  "Inking" .

 If you cannot ink the layer, see  "If You Cannot Draw on a Cel (Layer)" .
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Draw the rest of the cels
Create layers and ink the drawings for cels "2" and onward in the same way as cel "1".

When you have finished inking, your layers will look like this.

When you have finished inking, select the [Tool] palette → [Operation] tool → [Edit timeline] tool and click the canvas to check the motion of 
the line drawings. If there are any issues in the line drawing, fix them before coloring the drawings.

If you cannot ink the layer, see  "If You Cannot Draw on a Cel (Layer)" .

Cel "1"

Cel "2"

Cel "3"

Cel "4"
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Coloring
Create a coloring layer for each cel and start coloring.

In this case, we have created layers and colored each cel as shown below.

When you have finished coloring, select the [Tool] palette → [Operation] tool→[Edit timeline] tool. Click the canvas to check the motion after 
coloring. If there are any issues, fix the coloring.

 For details on coloring, see  "Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide"  →  "Basic Col-
oring"  and  "Drawing the Fine Details" .

 See  "If You Cannot Draw on a Cel (Layer)"  if you cannot color the layer.

Cel "1"

Cel "2"

Cel "3"

Cel "4"

Create layers for cels "2" - "4" and color them 

in the same way as cel "1".
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If You Cannot Draw on a Cel (Layer)
If you cannot draw lines or color on a cel in the [Animation] folder, check the following points.

Is the Animation Folder or Layer Folder Selected?
You cannot draw on cels if an animation folder or layer folder is not selected. Select the layer to be drawn on the [Layer] palette.
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Is the Layer Folder Name Displayed on the [Timeline] Palette?
Check that the name of the cel (layer folder) containing the layer to be edited is displayed on the [Timeline] palette. Cels in the [Animation] 
folder need to be specified on the [Timeline] palette before they can be edited.

If the name of the cel in the animation folder is different from the cel name specified on the [Timeline] palette, change the name of the cel on 
the [Layer] palette so that it matches the cel name specified on the [Timeline] palette.

In this example, there is no cel with the same name as cel "4" on the [Timeline] palette. Change the name "Folder 4" to "4".

The name of the cel to be edited is not 

displayed on the [Timeline] palette.

Cel name
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Has the Cel Been Added as a New Cel?
When you add a new cel to the animation folder, you need to specify the cel on the [Timeline] palette.

Right click the frame on the [Timeline] palette. This displays a popup menu. Select the name of the new cel you have added.

On the iPad, when pressing and holding a frame with your finger, a popup menu is displayed.

If you cannot see the frame where you want to specify the cel on the [Timeline] palette, change the playback time. 
See  "Change the Playback Time"  for details on changing this.

Newly added cel

Right click
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Has the Inking or Coloring Layer Been Created Outside the Layer Folder?
If the inking or coloring layer has been created outside the layer folder, drag and drop the layer into the layer folder.

 Play Your Moving Illustration
Click [Play/Stop] on the [Timeline] palette to play your moving illustration.

You can change the playback speed by editing the playback time (see the next section,  "Editing the Timeline" ).
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 Editing the Timeline
Change the playback time or the timing at which to display cels using the [Timeline] palette.

Change the Playback Time
The playback speed is currently too fast. Change it by making the playback time longer.

Move the mouse cursor to the [End frame] on the [Timeline] palette and drag it to the right. In this case, we are dragging it to the 8th frame.

The playback time is now longer.

Click [Play/Stop] on the [Timeline] palette to play your moving illustration. You'll notice that the playback time is longer but no cels or paper 
layers are displayed during the last part of the clip. Edit how the cels and paper layers are displayed (see the next section,  "Edit the Cel Dis-
play" .)

In DEBUT and PRO, you can extend the playback time to a maximum of 24 frames.

Drag

The playback time is now longer.
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Edit the Cel Display
Extending the playback time does not change the cel display. Change the cel display on the [Timeline] palette.

Change the Clip Display Time
The clip is the editing range indicating the area in which cels and layers are displayed. If frames in the clip are not displayed during part of the 
playback time, no cels or paper layers are displayed during that time.

In this case/example, you will change the clip length so that the cels and paper layer are displayed throughout the whole of the playback time.

1 Move the mouse cursor to the right end of the clip in the animation folder and drag it to the 
end frame of the playback time.
The shape of the mouse cursor changes to a left and right arrow when you move it to a position where you can change the display time of 
the clip.

Clip

Drag
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2 Move the mouse cursor to the right end of the paper layer clip and drag it to the end frame
of the playback time.

Deleting Cel Specifications
Now cels and paper layers are displayed up to the end, but playback is still too fast. Re-specify cels so that the movement matches the playback 
time on the [Timeline] palette. You will need to delete the cel specifications before re-specifying the cels.

1 Click cel "2" on the [Timeline] palette.

Dragging the clip to the left shortens the display time. If cels are specified in frames that are not included in the 
shorter clip, the cel specifications are deleted.

Drag
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2 Click [Delete specified cels] on the [Timeline] palette.

The cel specification for cel "2" is deleted.

3 Delete cels "3" and "4" in the same way.
All cel specifications other than cel "1" are deleted from the [Timeline] palette.
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Specify the Cels
Re-specify the cels for different frames.

1 Right click the third frame on the [Timeline] palette. If you are using an iPad, press and 
hold the third frame with your finger.

2 Select "2" from the popup menu.

Cel "2" is specified and displayed in the third frame on the [Timeline] palette. Cel "2" now appears when playing the third frame on the 
[Timeline] palette.

If it is difficult to hold down the frame on the iPad's [Timeline], pinch out on it to enlarge the [Timeline] palette. 
Pinching in on the [Timeline] palette restores it to its original size.
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3 Right click the fifth frame on the [Timeline] palette. If you are using an iPad, press and hold
the fifth frame with your finger. Select “3" from the popup menu.

4 Right click the 7th frame on the [Timeline] palette. If you are using an iPad, press and hold
the 7th frame with your finger. Select “4” from the popup menu.
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All cels are now specified.

Check the Motion
Click [Play/Stop] on the [Timeline] palette to play your moving illustration. Modify the playback time and/or cel specifications if there are any 
issues.

Your moving illustration is now complete.

Cel "1" Cel "2" Cel "3" Cel "4"
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 Saving the File
When your work is complete, save the file. Save the file in "CLIP STUDIO FORMAT" (extension: clip) if you want to edit
it in CLIP STUDIO PAINT again later.

1 Select the [File] → [Save].

2 Save your work in "CLIP STUDIO FORMAT" (extension: clip) in the [Save] dialog.
Selecting [Save] will save automatically, when using the iPad version.

To change the file name when saving, select the [File] menu → [Save As].

To open a saved file, select the [File] menu →[Open file].
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 Export Your Moving Illustration
You can export your finished moving illustration as a file such as an animated GIF or movie. Exported files can be
posted online via websites such as social media.

Animated GIF
Animated GIFs are supported by various web services such as social media. This is therefore an ideal format for posting your finished work 
online. Animated GIFs also have a smaller file size than movie files. However, they can only be exported in up to 256 colors.

This section explains how to export your finished work as an animated GIF.

1 Select the [File] menu→[Export animation]→[Animated GIF].

2 In the [Save As] dialog box, select the folder in which to save your work and click [Save].

3 The [Animated GIF export settings] dialog box is displayed. Check the settings and click
[OK].

If you will be posting your animated GIF on a web server such as social media, be aware that there may be file size 
limits such as a maximum [Width] or [Height]. Check the rules of the service you will be using before you export 
your work.

When using the iPad, the [Save As] dialog is not displayed. Please proceed to the next step.

If you export a canvas more than 560px long as an animated GIF, it is automatically resized to 560px.
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4 A message displaying the file size is displayed. Check the file size and click [OK].

An animated GIF file is created in the folder specified in step 2.

When using an iPad, the [File operation/Share] dialog box will be displayed, and the newly created animated GIF file can be checked.

By clicking [Share] in the [File operation/Share] dialog box, you can open animated GIF files in other environments or publish them to 
various social media sites.

Movie
Movie files can be exported as AVI files (extension: avi) or MP4 files (extension: mp4) with Windows, or as QuickTime files (extension: mov) 
or MP4 files (extension: mp4) in the macOS/iPad version.

Unlike animated GIFs, the color range is not reduced when exporting to a movie file. If you added sound files such as background music using 
CLIP STUDIO ACTION, these are included in the exported file. Movie files can play sound in addition to moving illustrations.

This section explains how to export your finished moving illustration as a movie file in MP4 format.

1 Select the [File] menu→[Export animation]→[Movie].

2 In the [Save As] dialog box, set [File Type] as [MP4].

If the file is too large for the web service you want to use, click [OK] and then export the file again in a smaller 
size. You can reduce the file size by setting smaller values for [Width], [Height] and [Frame rate] in the [Animated 
GIF export settings] dialog box.
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3 The [Movie export settings] dialog box is displayed. Check the settings and click [OK].

A movie file is created in the folder specified in step 2.

When using an iPad, the [File operation/Share] dialog box will be displayed, and the created movie file can be checked.

By clicking [Share] in the [File operation/Share] dialog box, you can open video files in other environments or publish them to various 
Social Media sites.
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Image Sequence
Export the frames of your finished moving illustration as a series of image files. The exported files are named with serial numbers in the order 
in which the frames appear in the moving illustration.

Image sequence files can be converted to a movie file or animated GIF by importing them into other software or uploading them to various web 
services.

This section explains how to export your finished work as an image sequence.

1 Select the [File] menu→[Export animation]→[Image sequence].

2 The [Image sequence export settings] dialog box is displayed. Check the settings and click
[OK].

An image sequence is created in the folder specified for [Export to] in the [Image sequence export settings] dialog.
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When using an iPad, the [File operation/Share] dialog box will be displayed, and the created image sequence can be checked.

By clicking [Share] in the [File operation/Share] dialog box, you can open image sequence files in other environments.Note that you can not 
open image sequences displayed in the [File operation/Share] dialog box with CLIP STUDIO PAINT.
CLIP STUDIO PAINT STARTUP GUIDE 272


	Before You Read This Guide
	Notations in This Guide
	About Operations Described in This Guide
	Signs
	Product Grades
	Trademarks and Copyrights

	Before Drawing a Work in CLIP STUDIO PAINT
	Operations Available in CLIP STUDIO PAINT
	A Natural, Realistic Touch With A Variety of Styles
	Variety of Painting Styles
	Resolution Free for Beautiful Lines and Easy Editing [PRO/EX]
	All the Functions You Need for Manga, Including Unlimited Tones [PRO/EX]

	Starting
	When using Windows/macOS
	Screen Configuration

	When using an iPad
	Screen Configuration
	Changing the interface color


	Preparations
	Change the Canvas Size and Resolution
	Changing the Settings
	Creating a New Canvas

	Try Drawing with the Drawing Tool
	Tips: If you make a mistake while operating

	Adjust the Pen Pressure

	Page Management [EX]
	Creating a Management File
	Configure the Binding Point and Start Page

	Managing Multiple Pages
	Page Manager Window
	Adding and Deleting Pages
	Changing the Page Order
	Setting a Spread or Single Pages
	Switching the Displayed Page


	Basic Canvas Operations and Shortcuts
	Basic Canvas Operations
	Scaling the Canvas Up and Down (Zoom In/Zoom Out)
	Showing the Whole Canvas
	Scrolling Across the Canvas
	Flipping the Canvas Horizontally
	Rotating the Canvas

	List of Frequently Used Shortcuts
	Edge Keyboard (iPad)

	Setting a Color
	Selecting a Color on the [Color Wheel] Palette
	Selecting a Color on the [Color Set] Palette



	Try Drawing an Illustration in CLIP STUDIO PAINT Basic Guide
	Process for Creating an Illustration: Basic Guide
	Rough Draft
	Creating a New Canvas
	Preparing the Drawing Tool
	Using the drawing tools (iPad)
	Drawing a Draft
	Correcting the Lines
	Finishing the Draft

	Inking
	What is a Layer?
	Tips: When displaying the layer palette on the iPad

	Creating a Layer
	Preparing the Pen Tool
	Inking the Drawing
	Correcting the Lines
	Drawing the Fine Details
	Finish Inking the Drawing

	Basic Coloring
	Coloring the Hair
	Preparing the Layers
	Preparing the Tool
	Adding the Basic Color
	Adding Shadow
	Coloring Unfilled Areas

	Coloring the Skin
	Adding the Basic Color of the Skin
	Adding Shadow (Without Runover)
	Adding a Gradient on the Skin

	Coloring the Wings
	Adding the Basic Color of the Wings
	Coloring with the [Gradient] Tool 1
	Coloring with the [Gradient] Tool 2

	Coloring the Clothing
	Coloring the White Background (Show Transparent Area)
	Coloring the Other Areas


	Drawing the Fine Details
	Drawing the Eyes (Combine Layers)
	Drawing the White of Eye
	Drawing the Eyelashes
	Coloring the Eye (Irises/Pupils)
	Joining the Layers

	Drawing Highlights
	Saving the Illustration


	Try Drawing an Illustration in CLIP STUDIO PAINT Advanced Guide
	Process for Creating an Illustration: Advanced Guide
	Touching Up a Work Using the Clipping Function
	Preparing the Layer (Setting the Clipping Mask)
	Preparing the Drawing Tool
	Touching Up Shadows 1
	Touching Up Shadows 2
	Touching Up the Highlights
	Touching Up the Reflected Light


	Touching Up Using the [Blending mode] of the Layers
	Drawing Shadow Using the "Multiply" Blending Mode
	Preparing the Layers
	Drawing the Shadows

	Drawing Light Areas Using the "Screen" Blending Mode
	Preparing the Layers
	Drawing the Light Areas

	Touching Up the Other Areas
	Coloring the Boots
	Coloring the Clothing


	Touching Up the Wings
	Preparing the Layers
	Creating Color Divisions in the Ground Color
	Touching Up to Add Texture
	Adding a Pattern

	Adjusting the Overall Color Tone of the Character
	Tonal Correction of the Skin Tone
	Adjusting the Overall Contrast
	Preparing the Layer Folder
	Drawing the Contrast

	Adjusting the Line Drawing Color

	Finishing
	Creating the Background
	Using Filters
	Saving the Illustration

	Note

	Try Drawing a Manga in CLIP STUDIO PAINT Monochrome Manga Guide [PRO/EX]
	Process for Creating a Monochrome Manga Draft
	Creating a New Manga and Storyboard
	Preparing the Manga and Creating a New File
	Configuring the Settings of the Storyboard Layer
	Changing the Layer Name
	Setting the Expression Color and Layer Color
	Setting the Draft Layer

	Drawing the Storyboard
	Finishing the Storyboard

	Creating Balloons and Dialog
	Creating a Balloon
	Ellipse Balloons
	Rectangle Balloons

	Adjusting the Shape of the Balloon
	Attaching a Tail to a Balloon
	Entering Dialog
	Adding a Reading for Text

	Draft
	Preparing the Layers
	Drawing a Draft

	Adding the Border Lines
	Creating a Frame
	Dividing a Frame Border
	Adjusting the Shape of the Frame Borders
	Bleed Settings
	Deleting Unneeded Frames


	Inking the Characters
	Inking the Background
	Inking the Effect Lines
	Saturated line
	Stream Lines
	Sea Urchin Balloons


	Fill in monochrome
	Creating a Layer for Filling in Monochrome
	Filling in White (Before Finishing)

	Finishing (Tones and Gradients)
	Pasting a Tone Layer
	Pasting a Gradient Tone

	Sound Effects Lettering
	Adding Edges to Sound Effects Lettering
	Making Corrections

	Saving the File
	Tips: Formats for Saving Files
	Printing[Windows/macOS]
	Tips: Types of Duotone



	Try Drawing a Manga in CLIP STUDIO PAINT Color Manga Guide [PRO/ EX]
	Process for Creating a Color Manga Manuscript
	Preparations before Creating a Color Manga
	Preparations
	Changing the Canvas Properties
	Hiding Layers Made as Tone
	Hiding the [Balloon] Layer and "Sound Effect" Folder


	Coloring the Characters
	Coloring the Base
	Coloring the Shadows
	Storing in a Layer Folder
	Coloring Other Parts

	Coloring the Background
	Changing the Saturated Lines
	Changing the Stream Lines
	Coloring with the Decoration Tool
	Preparing the Layers
	Drawing the Background of Frame 2
	Drawing the Background of Frame 3
	Drawing Over the Background Color


	Coloring Inside the Border Lines (Frame Borders)
	Coloring the Character in Frame 4
	Coloring the Background

	Coloring the Main Lines of the Characters and the Sound Effects
	Coloring the Main Lines of the Characters
	Coloring the Sound Effect Lettering
	Sound Effect Lettering in Frame 2
	Sound Effect Lettering in Frame 4


	Drawing and Adjusting the Fine Details
	Drawing the Fine Details
	Adjusting the Color


	Saving the File

	Make a Moving Illustration in CLIP STUDIO PAINT
	Process for Creating a Moving Illustration
	Planning and Draft
	Planning
	Creating a New Canvas
	Display the Timeline Palette
	Check the Screen
	Drawing a Draft
	Draw the First Cel
	Draw the rest of the cels
	Tips: Onion skin

	Check the Motion

	Inking and Coloring
	Creating a Layer Folder
	Inking
	Draw the First Cel
	Draw the rest of the cels

	Coloring
	If You Cannot Draw on a Cel (Layer)
	Is the Animation Folder or Layer Folder Selected?
	Is the Layer Folder Name Displayed on the [Timeline] Palette?
	Has the Cel Been Added as a New Cel?
	Has the Inking or Coloring Layer Been Created Outside the Layer Folder?


	Play Your Moving Illustration
	Editing the Timeline
	Change the Playback Time
	Edit the Cel Display
	Change the Clip Display Time
	Deleting Cel Specifications
	Specify the Cels
	Check the Motion


	Saving the File
	Export Your Moving Illustration
	Animated GIF
	Movie
	Image Sequence



